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Overview 
QMF for Workstation is an Eclipse-based, rich client desktop Java  application, 
that uses JDBC to connect to data sources to provide querying, reporting and Business 
Intelligence (BI) solution development and execution capabilities.  
 
This hands-on lab covers how to use QMF for Workstation to access IMS DB using the IMS 
Universal Driver. 
how to use QMF for Workstation to access IMS Databases 
 
QMF can be used  

 
– Allow users to graphically construct ad-hoc IMS queries 
– Create reports and dashboards that draw directly from IMS data 
– Roll out web-based graphical content that blends IMS data with relational and multi-

dimensional data sources 
 
The lab exercises cover the following topics: 
 
1.  Installing the IMS driver (FOR YOUR INFORMATION only) 
 
2.   Creating a personal repository.  
 
3.  Working with queries. 
 
4.  Developing reports using QMF forms. 
 
5.  Defining virtual data sources. 
 

Exercise 1: Configuring the IMS JDBC Driver 
QMF for Workstation uses JDBC drivers to connect to data sources. The product does not 
include the actual JDBC driver files. Administrators must define the location of the JDBC 
driver files. This exercise is for your information – for this lab, the IMS Universal Driver 
has already been installed into the QMF tool. 
 
 
How to get the IMS Universal Drivers 
The IMS Universal Drivers are shipped with IMS. 
 
The IMS distribution libraries (DLIBs) contain the master copy of elements in IMS and 
can be used to restore SYSMODs in the target library or to rebuild a target environment. 
These data sets are maintained by SMP/E. 
 
The IMS.ADFSJHFS: ADFSJHFS contains the type-2 and type-4 Universal driver Java 
class libraries used for IMS DB access through the JDBC and DLI for Java interfaces. 
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The TLIB data sets are the IMS SMP/E target libraries (SYSLIBs), and are the libraries that 
are used to run and use IMS.  
 
The following data sets that reside in a UNIX System Services (USS) file system are 
also maintained by the SMP/E APPLY processing: 
SDFSJCPS 
SDFSJTOL 
SDFSIC4J 
SDFSJCIC 
SDFSJCPI 
SDFSJHFS 
SDFSJRAR 
SDFSJSAM 
 
The IMS HFS data sets contain   
SDFSJCIC: Maps to PathPrefix/usr/lpp/ims/imsnn/imsjava/classic/cics/IBM/ 

SDFSJHFS: Maps to PathPrefix/usr/lpp/ims/imsnn/imsjava/IBM/ 

SDFSJSAM: Maps to PathPrefix/usr/lpp/ims/imsnn/imsjava/ivp/IBM/ 

SDFSJRAR: Maps to PathPrefix/usr/lpp/ims/imsnn/imsjava/IBM/ 

SDFSJCPI: Maps to PathPrefix/usr/lpp/ims/imsnn/imsjava/classic/IBM/ 

SDFSJTOL: Maps to PathPrefix/usr/lpp/ims/imsnn/imsjava/classic/dlimodel/IBM/ 

SDFSJCPS: Maps to PathPrefix/usr/lpp/ims/imsnn/imsjava/classic/classic/ivp/IBM/ 

SDFSIC4J: Maps to PathPrefix/usr/lpp/ims/imsnn/ico/IBM/ 

 
The IMS Universal JDBC driver (imsudb.jar) is used to make SQL calls with the JDBC API 
and can be download as a binary file from HFS path:  PathPrefix/usr/lpp/ims/imsnn/imsjava/IBM/  
where nn is the IMS version you have installed.. 
 
For this lab the imsudb.jar has already been downloaded and can be found at  
C:\share\Drivers 
 

> View the IMS Universal Driver JDBC driver configuration file 
 

1.  Launch QMF by double-clicking the DB2 Query Management Facility application on 
the desktop or via the Windows Start Menu.   

 
2.  When the application launches, you will see the Welcome page. You can ‘x’ out of this 

view.  
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       Click on the x by the Welcome tab to close the view. 
 

                    
 
3.  Open the Administrator perspective if you have not already done so. To open the 

Administrative perspective go to the menu pane and select: 
Window > Open perspective > Administrator.  

(If  Administrator is not in the list then Window > Open perspective >  Other > 
Administrator). 
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4.  Select Preferences from the View menu to open the Preferences window. 
 

               

 
 
5.  Select JDBC Libraries.  
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6. The JDBC Libraries page opens. QMF supplies pre-populated libraries named for 

specific databases including IMS. You can expand the IMS tab to see that the IMS 
Universal JDBC Driver has been installed.  
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Exercise 2: Create a personal repository 
 
A personal repository is a set of database tables that stores QMF for Workstation objects, 
such as queries and dashboards, as well as database connection information, QMF 
configuration information, and application data.  
 
To set up a personal repository, follow these steps: 
 

1. Select File -> New -> Other.   
 

                                

 

2.  When the Select a wizard opens, choose Personal Repository. 
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3. Select NEXT and enter a name. For example IMSQMFLABxx  where xx is your team 
number.  

 

                                   
 

          Click FINISH. 
 

4.  The IMSQMFLABxx Personal Repository connection information needs to be updated 
to connect to a repository: 

 
Expand  IMSQMFLABxx. Right-click Relational Data Source -> New -> Relational 
Data Source   
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5.  The Create New Relational Data Source window opens. This is where you can 
define your connection to a data source (IMS) and a specific PSB through IMS 
Connect.  For this exercise, your connection will be to the IMS Catalog PSB.   
 

 
 
 
In the Data Source Name field enter IMSBzserverosnn where nn is your team number. 
 
Set the connection type button to JDBC.  
 
In the JDBC Driver drop down list select IMS Universal JDBC Driver. 
 
Enter the following for the JDBC URL to access the IMS Catalog metadata:     
 
jdbc:ims://zserveros.demos.ibm.com:7013/DFSCP000:dpsbOnCommit=true;datastoreName=IMSB; 
 

 

 

(invoke the IMS JDBC driver) 
                                                                                                                            (access the IMSB system defined  
   (zserveros.demos.ibm.com is the host)                                                             in IMS Connect as a datastore) 
                             (7013 is the IMS Connect Port)                (Deallocate the PSB during commit processing)           
                                                                    (DFSCP000 is the PSB for the IMS catalog). 

 
Select NEXT. 
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6. When the window opens for your credentials, in the userid field enter IMPOTxx where 
xx is your team number.  In the password field enter the password provided by the 
instructor. Click OK. 

 

                                                 
 
 
                     During the course of the exercises, the following screens may appear:   
 

                                  
 
                     If so:          Click OK.                                           Click Finish. 
 
  

7. You should now be able to access the IMS Catalog. 
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                          Use the scroll bar until you see the PSB table.   
 

                                    
 
                      and right-click then use Open -> Table Viewer   
 

     

This shows the 
information in the 
IMS Catalog 
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This allows you to see all the PSBs as well as any other information you choose to view in the 
Catalog. 
 
 

Exercise 3: Accessing IMS if the catalog is unavailable  

 
For environments that do not have access to the metadata in the IMS Catalog, the IMS 
Enterprise Suite Explorer for Development (downloadable from the IMS home page 
www.ibm.com/ims which creates metadata) can save the information in a local file on the 
workstation. For this lab, the metadata created by the IMS Explorer for Development has 
been stored in the folder -   C:/share/IMS Universal Drivers Metadata.   
 
You will access two PSBs:  DFSIVP37 (on IMSD) and DFSSAM09 (on IMSB), using local 
metadata that has been saved on your workstation, 
 

1. Create another Data Source connection, this time for access to PSB DFSIVP37. Right 
click Relational Data Source NEW -> Relational Data Source   
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In the Data Source Name field enter IMSDDFSIVP37. 
 
Set the connection type button to JDBC. In the JDBC Driver drop done list select IMS 

Universal JDBC Driver. Enter the following for the JDBC URL to access the 
DFSIVP37 local file metadata:     

 
jdbc:ims://zserveros.demos.ibm.com:7001/class://dfsivp37.DFSIVP37DatabaseView:db

ViewLocation=C:/share/IMS Universal Drivers Metadata;fetchSize=0; 

 

- (//zserveros.demos.ibm.com) is the hostname where IMS Connect is running  
- (7001) is the IMS Connect port number that will send the request to the IMS system 

(IMSD) 
- The (class://) points to the metadata URL, (dfsivp37.) is a folder in the local file 

system, and (DFSIVP37DatabaseView) is the metadata    that was previously created 
with the IMS Explorer for Development  

- The dbViewLocation points to the local file system C:/share/IMS Universal Drivers 
Metadata  (you can use windows explorer to see this file structure) 

- fetchsize gives the JDBC driver a hint as to the number of rows that should be fetched from 

the database when more rows are needed. The number of rows specified affects only result sets 

created using this interaction. If the value specified is zero, then the hint is ignored and the 

driver returns as many rows as are available. The default value is zero.  

 

                                
 

Select NEXT. 
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In the userid field enter IMPOTxx where xx is your team number and enter the 
password provided by the instructor. Click OK. 
 

 

 

Expand the structure to view the data that is returned.  
 
 

 
2.  Create another IMSQMFLABxx Personal Repository connection.  This time for PSB 

DFSSAM09 on IMS system IMSB.  The URL for this connection also uses a local 
metadata file: 

 
Right click Relational Data Source NEW -> Relational Data Source .  
In the Data Source Name field enter IMSBlocalmetadata. 
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Set the connection type button to JDBC. In the JDBC Driver drop down list select IMS 
Universal JDBC Driver. In the JDBC URL drop down list enter the following:  

 
jdbc:ims://zserveros.demos.ibm.com:7013/class://dfssam09.DFSSAM09DatabaseView:dbViewLocation

=C:/share/IMS Universal Drivers Metadata;fetchSize=0; 

 
Note that access continues to be to the hostname of zserveros.demos.ibm.com but that the 
port number is 7013 which will allow the request to be sent to IMSB. 
 

                            
 

Select OK to close the template. 
 
Select NEXT. 
 
When the window for your security credentials pops up, enter IMPOTxx where xx is your team 
number in the userid field and the password provided by the instructor. 
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Select OK to close the login template. 
 
In the Repository Explorer you will see the tables in the IMS PARTS DB. 
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Exercise 4 – Working with queries 
 
This section introduces you to the query development facilities in QMF for Workstation. 
 
There are a number of ways to create a new query, including: 
 

• Browsing through your database structure and double-clicking on a given table. 
 

• Using the File->New->Query menu item or ‘New Query’ toolbar button. 
 

• Using the QMF command bar to directly display a given table with a default query. 
 

• Using the ‘Draw Query’ toolbar button. 
 

• Clicking on tables that have been arranged in an arbitrary folder structure in your QMF 
workspace. 

 
In our case, we will start by using the QMF command bar. 
 

1. Click on the ‘Show Command Bar’ toolbar button (fourth from the left).  The QMF 
command bar visibility is toggled.  Click on the button such that the command bar is 
visible.  

 

         
 

Alternatively, you can click on View -> Command Bar 
 
The command bar accepts QMF procedure commands.  You only need enough letters from 
the command’s name to allow QMF for Workstation to distinguish it from other procedure 
commands.   
 
We will use the DISPLAY command but you only need to enter ‘di’ since DISPLAY is the only 
command that starts with ‘di’. 
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2.  Enter di q.backordr into the Run command field and on the right in the Data Source field, 

choose the one that you last created which has the table, e.g., IMSBlocalmetadata. Press 
enter.  QMF for Workstation creates a default query and runs it. 

 
 

 
 
 

Review the SQL that was generated by clicking on the SQL tab toward the bottom. 
 
 

 
3.  Try another query.  Enter di q.A1111111 into the Run command field and in the Data 
source: drop down box select IMSDDFSIVP37 then press enter.  QMF for Workstation creates 
a default query and runs it. 
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4.  Sort the Results. 
 
Right click on the IO LAST NAME column and select either Sort Ascending or Sort 
Descending to view the results in a different order. 
 

  
 
 5.  Close the query by clicking on the X in the query tab. 
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Transferring Data to Microsoft Excel  

(this can be done back at your shop but cannot be done in this lab because 

Microsoft Excel is not installed)  

 
QMF for Workstation is capable of directly transferring query results to Microsoft Excel.  When 
running QMF for Workstation on a desktop with Excel installed, data can be immediately 
exported to Excel by pressing Ctrl+B or selecting the Results->Display Excel Sheet menu 
item.   
 

 
 
A screen capture of the outcome of exporting a query result set to Microsoft Excel using QMF 
for Workstation’s ‘Display Excel Sheet’ function.  The export is performed ‘live’ without the 
need to create and open an external file. 



  

21 

Exercise 5 – Developing Reports using QMF Forms 
 
In this exercise, we will apply a QMF form to the result set produced from the query that was 
created in the prior exercise. 
 

1. Click on the backorder tab to display the result set that you created earlier. 
 
 

                    
 

2. Click on the ‘Display a report’ toolbar button, or alternatively, click on Results -> 
Display Report tabs.  
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3.  The Display Report wizard allows users to either create a new report or apply an 
existing report to a given query result set.  Leave Create a new report selected and 
click on the Next button. 

 

                             
 

3. Select Create a classic report from the report type combo box.  Note the remaining 
options in the dialog – one can create a default report format or derive the report from 
the format already contained in the query result set.  

 
- Ensure that the Create from query and the use available data buttones are both 
selected then click on the Finish button. 

 

                                          
 
5.  The report is created and executed.  Note that the report format matches the layout of the 
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query. 
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Exercise 6 – Defining virtual data sources to simplify database 

schemas for non-technical users 
 
Virtual data sources allow QMF administrators to define simplified data schemas that make it 
easier for end users to work with your enterprise data.  Traditionally, QMF users have been 
required to understand the explicit data schemas in your data sources since they work directly 
with the tables and views when building queries and forms.  With virtual data sources, you 
can now define a level of simplification between the underlying data sources and the end 
users.  This has two distinct advantages: 
 

• Users are shielded from the complexities of the underlying data sources and only see 
relevant columns that pertain to their job function. 

 

• A metadata layer allows changes to the underlying data schema without necessarily 
altering the virtual schema used by queries, reports and dashboards.  This can be used to 
isolate BI content from database changes. 

 
1. Select the Administrator Perspective.  This displays the Repository Explorer. From the 

previous exercises you are probably already in the Repository Explorer. Otherwise, 
click on Window > Open perspective > Administrator 

 
2.  Expand IMSQMFLABxx  and right-click on Virtual Data Sources.  Select New-

>Virtual Data Source 
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3.  Enter IMS Data for the data source name and click on the Finish button. 
 

                                     
 
4. Expand the new IMS Data virtual data source and note that it appears much like any other 

data source in the repository explorer, complete with a tables tree item. 
 

                                   
 
Virtual data source tables can be added using two key approaches: 
 

• Adding tables from real data sources into the virtual data sources.  Once added, the 
table name and columns can be renamed and specific columns can be removed from the 
virtual data source copy. 

 

• Adding saved QMF queries into the virtual data source’s table collection.  The query 



  

26 

will appear as a regular table.  As above, the table name and columns can be renamed 
and specific query columns can be removed. 

 
4. We will copy a table from an existing data source.    

- Locate the DFSIVP37 A1111111 table in the IMSDDFSIVP37 Data Source, listed 
under IMSQMFLABxx->Relational Data Sources tree item.   
 

- When located, select the table and hold left mouse key to drag to the table folder in 
Virtual Data Sources. Repeat to copy  table from IMSBLocalmetadata data source. 
 

 

   
 

6. Right-click on the A1111111 table and select rename.  Type IMSPerson for the table 
name. 
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7.  Expand the table to view the columns and right-click on the io-lastname column.  Rename 
it to IMSLastName. 
 
 
8.  Right-click on the io-extension column and select delete to remove it from the virtual 
table.  Any number of columns can be removed from a virtual data source table. 
 
 
9.  Double-click on the tabs for each of the tables to view the schemas.   
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This concludes the hands on lab.  Thank you for taking the time to complete this set of 

exercises. 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


