What You Need to Know About CICS Java Performance

Ian Burnett
CICS TS for z/OS Performance Lead, IBM

SHARE in Orlando

Tuesday, 11th August

Ian Burnett
IBM CICS TS for z/OS Performance Lead
ian.burnett@uk.ibm.com
@IanBurnett
Legal Disclaimer

- The information contained in this publication is provided for informational purposes only. While efforts were made to verify the completeness and accuracy of the information contained in this publication, it is provided "AS IS" without warranty of any kind, express or implied. In addition, this information is based on IBM's current product plans and strategy, which are subject to change by IBM without notice. IBM shall not be responsible for any damages arising out of the use of, or otherwise related to, this publication or any other materials. Nothing contained in this publication is intended to, nor shall have the effect of, creating any warranties or representations from IBM or its suppliers or licensors, or altering the terms and conditions of the applicable license agreement governing the use of IBM software.
- References in this presentation to IBM products, programs, or services do not imply that they will be available in all countries in which IBM operates. Product release dates and/or capabilities referenced in this presentation may change at any time at IBM's sole discretion based on market opportunities or other factors, and are not intended to be a commitment to future product or feature availability in any way. Nothing contained in these materials is intended to, nor shall have the effect of, stating or implying that any activities undertaken by you will result in any specific sales, revenue growth or other results.
- Performance is based on measurements and projections using standard IBM benchmarks in a controlled environment. The actual throughput or performance that any user will experience will vary depending upon many factors, including considerations such as the amount of multiprogramming in the user's job stream, the I/O configuration, the storage configuration, and the workload processed. Therefore, no assurance can be given that any individual user will achieve results similar to those stated here.
- IBM, the IBM logo, and WebSphere are trademarks of International Business Machines Corporation in the United States, other countries, or both.
- Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Topics covered in this session:

• An overview of the CICS Explorer
• An overview of the IBM Health Center
• How to install the IBM Health Center into CICS Explorer
• A look at some useful views within the Health Center
CICS Explorer

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Overview

- Runs on workstation
- Graphical interface
  - Based on Eclipse
- View and manage multiple CICS TS regions easily
- Task-oriented views
- Context-sensitive resource editors and wizards
- Excellent integration with CICS tools
- Also includes IBM Explorer for z/OS
Views

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Systems view
Complete your session evaluations online at www.SHARE.org/Orlando-Eval
IBM Health Center

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
What is the IBM Health Center?

- Diagnostic tool for IBM Java Virtual Machine (JVM)
- Two components
  - An agent installed into the JVM
  - A graphical client on your workstation

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Health Center Client

- One of the tools supplied by the IBM Support Assistant
- Stand-alone Eclipse application
- Plug-ins for an Eclipse environment
  - CICS Explorer is an Eclipse environment
Installation

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
A repository is an Eclipse concept – a location (either on your local disk or on a remote server) which contains one or more features which may be installed into an Eclipse environment.

Part 1: Installing workstation client

- Add a new repository to an existing CICS Explorer instance
  - Help → Install new software ...
  - Add...
    - public.dhe.ibm.com/ibmdl/export/pub/software/websphere/run
times/tools/healthcenter/
- Select the Health Center tools
- Click Next through the following screens
  - Includes acceptance of licence agreement
- Will require a restart of CICS Explorer
Installation selection screen

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Part 2: Installing Health Center agent into CICS

- Add parameters to CICS JVM profile

```
OVERTYPE TO MODIFY
CEDA DEFINE JVMserver( MYJVMMSRV )
JVMserver  : MYJVMMSRV
Group       : ISB
DESCRIPTION ==>
Status      ==> Enabled
Jvmprofile  ==> MYJVMPRF
Lerunopts   ==> DFHAXRO
Threadlimit ==> 015
```

This file on HFS (see JVMPROFILEDIR)
Agent parameters

• Simple case:
  – Start agent immediately and open a port
  – -Xhealthcenter:port=1972

• Advanced usage:
  – Start collecting when client connects
    -Dcom.ibm.java.diagnostics.healthcenter.data.collection.level=off
  – Collect data on z/OS system (no transfer to agent)
    -Dcom.ibm.java.diagnostics.healthcenter.data.collection.level=headless

• Options described in Help section of CICS Explorer

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Agent starting

- The agent will initialize when the JVM server is started
- Will issue messages like the following to stderr

Aug 06, 2015 1:25:51 PM
com.ibm.java.diagnostics.healthcenter.agent.mbean.HCLaunchMBean <init>
INFO: Agent version "3.0.0.20141209"
Aug 06, 2015 1:25:51 PM
com.ibm.java.diagnostics.healthcenter.agent.mbean.HCLaunchMBean createJMXConnector
INFO: IIOP will be listening on the next available system assigned port. Use
com.ibm.java.diagnostics.healthcenter.agent.iiop.port to specify a port
Aug 06, 2015 1:25:51 PM
com.ibm.java.diagnostics.healthcenter.agent.mbean.HCLaunchMBean startAgent
INFO: Health Center agent started on port 32105.

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Verification

- You can check the Health Center agent is listening using the `netstat` command

```
netstat -tulp
```

```
MVS TCP/IP NETSTAT CS V2R1
User Id Conn State
------- ---- ----
IBAOR001 09290784 Listen
    Local Socket: ::32105
    Foreign Socket: ::0
```
Connecting

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Installation of IBM Health Center adds a collection of new perspectives which allow you to customise your screen based on your area of interest.
Create a new connection

- Open the Health Center Environment perspective
  - Window → Open Perspective → Other ...
  - Health Center Environment
- Create a new connection
  - File → New Connection ...
  - Enter hostname, port and authentication details
  - Click Finish to connect
The environment perspective is a launchpad for other perspectives which provide more detailed information about the connected JVM.
We now move on to looking at some of the data which the Health Center client can display.
Density of class loading over time  
Which classes were loaded at which time  
Whether a class was loaded from the class sharing cache  
Also available is class histogram data  
A snapshot of the classes that are in the heap  
The amount of heap space that the instances are occupying
The Just-In-Time (JIT) compiler within the JVM uses a sampling approach to decide which Java methods should be more aggressively compiled. This sampling data is exposed in Health Center in the profiling perspective.

This data provides method-level profiling of the applications running in the JVM.

Methods can be filtered by class or package name.

The Method profile view shows sample counts for specific methods.

Self is when the method is at the top of a call stack and tree is when a method appears in a call stack.

Additionally the Invocation and Called method views allows you to analyze the call path of each profiled method to ascertain how it was invoked, and what further methods it calls.
The Garbage Collection perspective provides a set of views to assist in analyzing the garbage collection (GC) process used by the JVM to manage memory in the JVM heap.

Using the default gencon GC policy splits the Java heap into two areas, the new or nursery area, and the old or tenured area. CICS JVM server statistics call new or nursery activity minor GC and call old or tenured activity major GC.

The Summary view provides detailed information on the GC process. Much of this information is also displayed in the CICS Explorer JVM Servers view, Object allocations view can be enabled by using Monitored JVM -> Garbage Collection and allocated data collection and then select Enable collection of object allocation events within and choosing low and high thresholds.
Object allocations

- Monitored System → Garbage Collection and allocation data collection ...

Use this view to identify code that is allocating large objects

Set low and high thresholds using Monitored JVM->Garbage Collection and allocation data collection
Object allocations view

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Use these views to identify code that is allocating large numbers of objects outside of the thread local heap.

Enable collection of call stacks to show call hierarchy Monitored JVM -> Garbage Collection and allocation data collection
Current threads view can be filtered

Thread stack can be used to show call stack
The Locking perspective profiles Java lock (aka monitors in Java) usage and helps identify points of contention in the application or Java runtime environment that prevent the application from scaling.

Useful metrics are:-

- **% miss:** percentage of non-recursive requests that had to wait for the lock
- **Slow:** number of times a requests had to wait
- **% util:** percentage of time this lock was held during the measurement interval
Controlling diagnostics

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Various JVM diagnostics actions can be driven from the Health Center client by using Monitored JVM
- Request a dump to produce either Heap, System or Javacore dumps to a file
- Garbage Collection to select verbosegc data be written to a file
- Trace settings to enable and disable Java method tracing

Dumps and verbosegc data can be analysed with tools provided by the IBM Support Assistant
Verbose garbage collection

- Monitored System → Garbage Collection and allocation data collection...

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Bonus tips

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Saving data for later analysis

- Health Center uses temporary backing files
  - Rolling data storage onto your workstation
  - Each file maximum 2.5 GB
  - Default of maximum 1 file
  - Window → Preferences → Health Center → Data Storage Settings
  - Files are discarded when Health Center is closed

- Files can be saved
  - File → Save Data ...
  - Can be opened at a later date without a live connection
If an application generates more data than Health Center can process, it is possible that Health Center might lose some data. If data loss occurs, you see a message about dropped data points in the agent connection view.

You can reduce the likelihood of losing data by turning off the collection of data from areas that you are not interested in.

To access these options, use Monitored JVM > Data Collection Settings.
CICS Explorer and the IBM Health Center are not the only sources of Java performance information when running Java applications in CICS. In this section we look at some other sources of information available to you when investigating Java performance within CICS.
CICS statistics contains several important metrics which are produced for each JVMSERVER in the CICS region.
... a continuation of the previous slide.
All of the monitoring data which is available for non-Java CICS tasks is also available for tasks containing Java programs.

Also available are several fields which help identify where tasks are waiting, as well as understanding at a task level which tasks are benefitting / would benefit from offload to a specialty engine.

CICS monitoring data

- Many fields available in CICS monitoring data for JVMSERVER
  - All of the "regular" monitoring data
  - JVMSUSP – JVM suspend time
  - JVMTHDWT – JVM server thread wait time
  - T8CPUT – Time spent on a CICS T8 TCB
  - CPUTONCP, OFFLCPUT – Calculations of offload to specialty engine
Questions?

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Session 17676

Ian Burnett
ian.burnett@uk.ibm.com

Thank you

Complete your session evaluations online at www.SHARE.org/Orlando-Eval
Reference material

• IBM Health Center
  – ibm.com/developerworks/java/jdk/tools/healthcenter/

• IBM Support Assistant
  – ibm.com/software/support/isa/

• CICSdev blog post
  – ibm.com/developerworks/community/blogs/cicsdev/entry/hcandjvmservers

• CICS Explorer
  – ibm.com/software/products/en/cics-explorer

Complete your session evaluations online at www.SHARE.org/Orlando-Eval