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Overview  

 

File Manager 

File Manager is a single toolset you use to work with a broad spectrum of z/OS files and data bases, 

including VSAM, IAM, and QSAM files, PDSes and libraries, DB2 and IMS databases, HFS files, OAM 

files, CICS queues, Websphere MQ queues, and tapes. 

File Manager provides powerful formatted editors and viewers, and also provides a full complement of 

on-line and batch utilities to copy, extract, and load data, to create files and data bases, compare and print, 

and many other utility functions. 

File Manager has a conventional 3270 interface that can be accessed from TSO or CICS. There is also an 

eclipse GUI interface that is available in the PD Tools Studio, and will also run in RDz, z/OS Explorer 

and CICS Explorer. 

 

This workbook 

This workbook contains instructions for lab exercises that are designed to give you hands-on experience 

for the eclipse interface of IBM File Manager for z/OS. 

 

Reference 

Product manuals and other information about IBM File Manager for z/OS, and the other IBM problem 

determination tools, are available on the Web at URL:  

http://www.ibm.com/software/awdtools/deployment    

 



 

____________________________________________________________________________________ 

Page 3 IBM File Manager for z/OS base feature lab exercises 

Lab Exercise 1 

Getting started with the File Manager perspective 

 

In this exercise you will: 

� Open the File Manager perspective in the Eclipse workbench. 

� Learn how to display help information for File Manager. 

 

1. Before you begin, you must have the Eclipse interface open on your workstation. If you aren’t sure how to 

open it, please ask. 

 

In eclipse, a perspective is a set of views (windows), menus, and options that provide a set of functions. The 

File Manager interface is a perspective. Before you can use File Manager, you need to open it’s perspective.   

 

2. Opening the File Manager perspective. 

a.  From the menu bar near the top of the eclipse workbench, select Window > Open Perspective > File 

Manager. 

i. Note: If “File Manager” isn’t shown as a selection, then the File Manager perspective is already 

open and you can proceed to the next step. 
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b. The File Manager perspective is displayed. Note that the contents of the Systems Information view may 

be different or even blank on your system. 

 

 

c. Notice that there are several views (windows) in the File Manager perspective. By default, the Systems 

Information view is displayed in the upper left. In the next exercise, you will use the Systems 

Information view to work with files. From the Systems Information view, you can initiate actions 

including: 

• Display a list of your files 

• Display a list of files based on a name filter 

• Edit or view a file 

• Copy or export a file 

• Compare two files 

• and other actions 

d. You can display help information to assist with various features of File Manager. To open the help 

dialog, select Help > Help Contents. 
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e. The help dialog is displayed. 

f. To expand the File Manager help topics, click the plus ( + ) next to IBM File Manager User Guide. 

 

 

g. Under IBM File Manager User Guide, select Editor > Starting File Manager Base Editor. 

 

 

h. The selected topic is displayed. 

i. Now you have seen how to display general help information. Close the help dialog: click the X (close) 

icon in the upper right corner of the window. 
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j. You can also display a list of keyboard commands. In the eclipse workbench Select Help >  Key Assist. 

 
 

k. A list of keyboard commands is displayed. 

 

l. Now that the File Manager perspective is open, and you know where to find help, you are ready to start 

using File Manager in the following exercises. 
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Lab Exercise 2 

Working with z/OS data sets in the Systems Information view 

 

In this exercise you will: 

� Display a list of your data sets 

� Create a query to display a list of data sets based on a name pattern 

� Use the filter bar to filter all lists 

 

 

1. Before beginning this exercise, you must have a connection to a z/OS system. If you are not sure how to 

connect, or which system you should use for this exercise, please ask. 

2. You can use the Systems Information view to display a file or a list of files on a z/OS system, and work with 

files using File Manager. Notice that under the zOS system definition, one of the selections is ‘Data Sets’.  

a. Under the name of the z/OS system that you will access during this exercise, click the small triangle 

next to  Data Sets. 

 

b. The ‘Data Sets’ selection is expanded to show ‘Browse My Data Sets’. 
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3. When you connected to the z/OS system, you created or selected a ‘credential’, which specified a User ID 

on the z/OS system. The ‘Browse My Data Sets’ selection will display a list of files on the z/OS system 

whose names begin with that User ID. 

a. Click the small triangle next to Browse My Data Sets, to expand it. 

 

 

b. A list of data sets that begin with your User ID are displayed. 
• Note that if a large number of files start with your User ID, the list is grouped under indexed 

headings that can be expanded individually. This example shows the list displayed under two 

groupings.   
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4. You can create a query to display a list of data sets based on your own filter. 

a.  Right-click Data Sets, then select Add Query. 

 

 

b. Type your-id.ADLAB.C** in the Query field, and click OK.  (Where your-id is your z/OS User ID). 

 

c. A list of matching files is displayed. 
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d. Tip: You can use these wildcard characters in a query: 
• **  (two asterisks) zero or more characters in any number of qualifiers 

• *   (one asterisk) zero or more characters in only one qualifier 

• %  (percent sign) one character 

e. Tip: You can define as many queries as you want. If you are familiar with working with z/OS files from 

TSO, a query is similar to a 3.4 data set list. Since you can have more than one query, it is similar to 

having the ability to have multiple 3.4 file lists all at the same time. This is one of the advantages of the 

eclipse interface for File Manager. 

5. You can enter a search string to filter all file lists. 

a. In the filter area, Type lab and notice the result. Only files that contain the letters ‘lab’ in the name are 

displayed. 

 

b. Continue typing lab.list and notice the results. 

 

c. Clear the contents of the filter area to display all files again. 
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d. Tip: Use the filter bar to limit all of the file lists. It even works for PDS and library member names when 

they have been expanded to show the members.  

6. You can modify or remove an existing query. 

a. Right-click the query that you added, then select Modify.   

 

b. Change the query to your-id.ADLAB.L** and click OK. 

 

c. The list now shows files according to the new filter in the query. 

7. You have completed this exercise. Now that you can display a list of files on a z/OS system, you are ready 

to continue with the next exercises. 
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Lab Exercise 3 

Using the editor and viewer 

 

 In this exercise you will: 

� Open a file in the editor or viewer 

� Open a file in the editor or viewer, using a copybook as a layout 

� Learn to use the basic features of the editor, including navigating a file, finding data in a file, changing 

data, and inserting, deleting and sorting records 

� Learn to exit the editor and save changes 

 

1. Before you open a file in the editor, it is easiest to create a query that shows the file in a list. 

a. Right-click Data Sets, then select Add Query. 

 

 

b. Type your-id.ADLAB.CUST** in the Query field, and click OK.  (Where your-id is your z/OS User 

ID). 

c. A list of matching files is displayed, including your-id.ADLAB.CUST1. 

2. You can open a file in the editor without a copybook or template  

a. Double-click your-id.ADLAB.CUST1 in the list.   
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b. The Editor Options dialog is displayed. Notice that the name of the file is already entered in the 

‘Resource’ field. 

• Ensure that the ‘Copybook or Template: Data set name’ field is blank. 

• Click the Edit button. 

 

 

c. The editor is displayed. Notice that there are two views of the data. The multiple record view appears at 

the top by default, and the single record view appears at the bottom and displays only one record at a 

time. 

• Tip: If you select (click) a record in the multiple-record view, that record displays in the single 

record view. 
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d. To close the file, click the X on the tab that shows the file name in the multiple record display. 

 

 

3. Next, you will start another editor session, but this time you will specify a copybook that will be used as a 

layout in the editor. 

a. Double-click your-id.adlab.cust1.   

b. The Editor Options dialog is displayed.  
• In the Copybook or Template Data set name field, type your-id.ADLAB.COPYLIB(CUST1). 

• Click the Edit button. 
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c. The editor display provides both multiple-record and single-record views with field level mapping 

(formatting).  Notice that the data is mapped by field names in the copybook. 

 

 

4. You can control the display modes in the multiple-view display. 

a. The multiple-record view has two display modes. Formatted mode displays the data formatted according 

to the fields in the layout. Character display mode shows unformatted data. 

•  To toggle the mode, right-click directly on the field headings line, then select Switch Mode.   

♦ Tip: You can also use the Switch mode icon on the toolbar. 
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b. The multiple-record view display is changed to character mode. In character mode, the data is not 

formatted according to the fields in layout. 

  

c. Toggle the format again: 

• Right-click in the data area, then select Switch Mode.  

 

d. The data is displayed in formatted mode again. 
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e. You can re-arrange the fields in the formatted multi-record display. 

• Drag and drop the ADDR field to the left. 

 
• After the drag and drop, the field displays in a different position. 

♦ Note: Re-arranging fields only affects how data is displayed, is does not modify where data is 

stored in the records. 

f. In formatted mode, notice that you can display information about fields. 

• Hover the cursor over a field name, but do NOT click. 

• The field information appears automatically in a pop-up box. 

 

5. You can also control the display modes in the single-view display. 

a. In the single-record display, select View Mode > Dump Mode. 
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b. The single-record display is changed to dump mode. In dump mode, field names are not shown. 

c. Switch back to single mode: 

• Select the ‘View Mode’ pull-down, then select Single Mode. 

d. The single-record display is changed back to single mode, and the field names are shown again. 

6. There are many actions that you can select in the editor or viewer, and there are many ways to select an 

action. Use which ever method or methods that you prefer. Four methods are: 

i. You can select the File Manager menu option, and select an action from the menu. 

 
ii. You can use one of the keyboard command equivalents. The keyboard equivalents are shown on the 

File Manager menu. 
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iii. You can right-click on the heading area of the multi-record view, and select an action from the 

context menu. 

 
iv. You can click an action icon in the tool bar. 

 
 

7. Click any record in the multiple-record display, and notice that it appears automatically in the single-record 

display.  
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8. A view can be expanded. 

a. Double-click the tab of multiple-record display. 

 

b. Notice that the view is expanded to the full window. It can be helpful to expand a view to display more 

data. 

c. Double-click the tab again, and the view is restored to its original size. 

9. You can scroll to other records in the file. 

a. Use the scroll bar on the right to scroll down and up. 

 

10. The ‘Navigation’ field can be used to directly scroll to (locate) a record in the file. 

a. Type 75 in the Navigation field and press Enter. 

 
 

b. The file is scrolled to record number 75. 
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11. You can also locate a column name. 

a. Right-click on the column heading line, then select Locate Column. 

 

b. The ‘Locate Field’ dialog is displayed. 

c. Select Occupation, then click OK. 

 

d. The display is positioned so that the Occupation field is visible. 
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12. You can use a special dialog to find and replace data. 

a. Right-click on the column heading line, then select Find/Replace. 

 

 

b. In the Find field, type ann, then click Find.  (Note: The default navigation is ‘Next’.) 

 

c. Notice that the next occurrence of ‘ann’ was found. 

d. The search can be limited to a specific field or fields. 

• Leave ann in the ‘Find’ field 

• Click Field. 
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• The Field Selection dialog is displayed. 

• Click the Deselect All button. 

• Select the ADDR field, then click OK. 

 
 

• Notice that the data was found, and that only the ADDR field was searched. 
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13. After finding data, the display can be reset to remove the highlighting where data was found. 

a. Click Reset to remove the highlighting. 

 

 

14. The Find/Replace dialog can also be used to replace data in a specific field. 

a. In the Find/Replace dialog, type Gulf in the ‘Find’ field and Bay in the ‘Replace with’ field, then click 

Replace.   
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b. Notice that data was found and changed in a record. 

15. Sorting records 

a. To sort records, click on any field name.  (Note:  You can also select the Sort icon on the Menu Bar.)   

b. The ‘Sort Options’ dialog is displayed. 

c. Click the Add Criteria icon. 

 

 

d. The ‘Sort by Field Reference Criteria’ dialog is displayed. 

e. Select ACCT-BALANCE from the field reference list, then click OK. 
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f. In the ‘Sort Options’ dialog, click OK. 

g. Notice that the records are sorted. 
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16. When you exit from the editor, you have the option to either save or cancel the changes. 

a. Click the X on the tab with the file name. 

b. In this example, click No to cancel all changes made to the file.   

 

17. The editor session ends. 

18. You have completed this exercise. 
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Lab Exercise 4 

Working with templates 

  

In this exercise you will: 

� Learn how to create a new File Manager template based on a copybook 

� Use a template to: 

a. display only selected records in a file 

b. display only selected fields in each record  

� Learn other basic features of templates 

 

Introduction to File Manager templates 

When you use the File Manager editor or viewer, you can specify a layout in the form of either a copybook 

or a template. If you specify a copybook, the editor/viewer can display records formatted according to the 

fields in the copybook. While a copybook defines the record layout, it cannot be used to select only a subset 

of records. 

A template, like a copybook, also has fields and defines the record layout. In addition, in a template you can 

specify: 

- Record selection criteria (so that only the selected records will display) 

- Field selection (so that only selected fields will display) 

- Formatting of individual fields (for example, to always display a certain field in hexadecimal) 

- And other formatting and data manipulation settings 

You can use an existing copybook as the basis for a new template. All of the fields in the copybook are 

copied into the new template, and then you save the template. Templates are stored in PDS or library data 

sets. After you have saved a template, you can re-use it again whenever you need it. 

Templates can be used by other File Manager utilities other than just the editor and viewer. For example, if 

you have a template that selects records, you can use it with the File Manager copy utility, and only the 

selected records will be copied.  

The following exercises will help you become familiar with File Manager templates. 

 

1. In the next few steps, you will create a new template, using an existing copybook as a model. There are 

several methods you can use to create a new template. One method is to use features that are built into the 

editor/viewer dialog, which you will do in the following steps. 

2. Check that you have the file your-id.ADLAB.CUST1 in any list under ‘Datasets’ in the Systems 

Information view. A query was added in a previous exercise that should display it. 

a. If this file is not displayed in any list, add a new query that will display it. 

b. If the file is not displayed, and you are not sure how to create a query to display it, refer back to exercise 
2 and add a query before continuing. 
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3. First, specify certain File Manager options that control how records are displayed in the editor when record 

selection criteria is used. 

a. Select Window > Preferences from the menu. 

 

 

b. The Preferences dialog is displayed. 
• Select File Manager > Formatted editor. 

c. The  ‘Formatted Editor’ preferences are displayed. Ensure that you have all of the following options 

selected (check marked): 

• ‘Group NOT SELECTED records.’ 

• ‘Group SUPPRESSED records.’ 

• ‘Display shadow lines for excluded record groups.’ 

• ‘Display shadow lines for not selected record groups.’ 

• ‘Display shadow lines for not suppressed record groups.’ 

d. Click the Apply button, then click the OK button. 
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4. Next you will use the file editor dialog to create a new template based on an existing copybook, and you 

will also specify record selection criteria in the template: 

a. From any file list under ‘Datasets’ in the Systems Information view, double-click the data set named 

your-id.ADLAB.CUST1. 

b. The Editor Options dialog is displayed. 

c. Type or select your-id.ADLAB.COPYLIB(CUST1) in the Copybook or Template Data set name field.  

d. Click the ‘Edit Template’ icon, which is located just to the right of the copybook name.   

 
 

e. The template-editing dialog is displayed. Notice that the fields from the copybook were automatically 

copied into the new template. 

• Click the Build Selection Criteria button (located to the right of the ‘Selection Criteria’ field). 
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f. The ‘By-Field Criteria Builder’ dialog is displayed. 

• Click the Add New Criteria button. 

 
 

g. Note: In this example, you will specify selection criteria that will select records where the text ‘ANN’ is 

contained anywhere within the NAME field. 

h. The ‘Field criteria specification’ dialog is displayed. 
• Select (click) the Name field 

• Click the operator pull-down 
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• Select the CU (contains) operator.  

♦ Note: A CU operator will perform a substring search in the specified field looking for the 

matching string. It is not case sensitive. 

 
 

• Type ANN in the Value field, then click OK. 
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i. The ‘By-field Criteria Builder’ dialog is displayed again. Notice that the specified selection criteria is 

shown. 

• Click the OK button. 

 
 

j. The template editor is displayed again. 

• Click the Save As button to save the template. 
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k. The ‘Save As’ dialog is displayed. 
i. Type your-id.ADLAB.TEMPLATE(CUST1) in the Resource name field, then click OK. 

l. The template editor is displayed again. 

i. Click OK. 

m. The ‘Editor options’ dialog is displayed again. 
• To use the new template, enter: your-id.ADLAB.TEMPLATE(CUST1) in the Copybook or 

Template Data set name field. 

• Click Edit. 
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. 

 

n. Notice that only records that match the selection criteria in the template are displayed. 

 

o. Close the editor session. 
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5. In addition to selection criteria for records, a template can also be used to select and re-order fields, and 

customize how fields are displayed. 

a. From any file list under ‘Datasets’ in the Systems Information view, double-click the data set named 

your-id.ADLAB.CUST1. 

b. The Editor Options dialog is displayed. 
• Type or select your-id.ADLAB.TEMPLATE(CUST1) in the Copybook or Template Data set 

name field. This is the same template that you just created. 

• Click the ‘Edit Template’ icon, which is located just to the right of the copybook name.   

 
 

c. The template-editing dialog is displayed.  

d. Next you will select fields for display. 
• Click inside the ‘Selected’ column for the CUST-ID field. Click again until an ‘S’ (for selected) 

appears.  

 



 

____________________________________________________________________________________ 

Page 37 IBM File Manager for z/OS base feature lab exercises 

• In the same way, also select the NAME, ACCT-BALANCE, CITY, STATE, and 

OCCUPATION fields. 

 

e. Next you will change the display order of the fields, so that the NAME field will display first and the 

OCCUPATION field will display second. 

• In the ‘Sequence’ column, type  1  for the NAME field, and  2  for the OCCUPATION field. 

 

f. Click the Save button to save the changes to the template, then click the OK button. 

g. The  ‘Editor options’ dialog is displayed again. 
• Ensure that the template name  your-id.ADLAB.TEMPLATE(CUST1) is specified in the 

Copybook or Template Data set name field. 

• Click Edit. 

h. In the editor, notice that now only the selected fields are displayed, and they are in the specified order. 
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6. Close the editor session. 

7. You have completed this exercise. 
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Lab Exercise 5 

Allocating new data sets  

  

In this exercise you will: 

� Learn how to allocate a new z/OS data set from File Manager using the Systems Information view 

 

 

1. You can allocate a new non-VSAM or VSAM data set from the Systems Information view. In this example, 

a non-VSAM data set will be allocated. The example will use a model. It is not necessary to use a model, 

but using a model simplifies the process. 

2. Allocating a non-VSAM data set.  

a. From a data set list in the Systems Information view, right-click your-id.ADLAB.CUST1 (to use as a 

model), then select Properties. 

 

 

b. This loads the properties values for the existing file, which will be used for the new file allocation. 

 

 



 

____________________________________________________________________________________ 

Page 40 IBM File Manager for z/OS base feature lab exercises 

c. Next, right-click your-id.ADLAB.CUST1, then select Allocate Wizard. 

 

 

d. The ‘Allocate Data Set Wizard’ dialog is displayed. 

• Type your-id.ADLAB.CUST1.NEW in the Data set field, then click Next.   

• In the Allocation Parameters pop-up, click Finish. 

 

 

e. If the file was allocated, a message is displayed indicating the successful creation.  

• Click OK to clear the message. 
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f. The new data is displayed in a data set list, if the name matches one of your queries. 

 

 

3. Note: You can allocate a new VSAM data set by following a similar process, except that you would select a 

VSAM data set type in the Allocate Wizard dialog, and specify the appropriate characteristics for the 

VSAM file. 

4. You have completed this exercise. 
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Lab Exercise 5 

Copying data sets  

 

 

1. You can run the File Manager data set copy utility from the Systems Information view. 

a. From a data set list in the Systems Information view, right-click your-id.ADLAB.CUST1 (to use as the 

input file), then select Copy Wizard. 

 
 

b. In the Copy Destination Resource field, type your-id.ADLAB.CUST1.COPY, then click Next.     

• (Note:  If the destination data set does not exist, it is allocated automatically using the input data 

set as a model.) 

 

c. On the Template Selection screen, click Next.   

• (Note:  An input and/or output copybook or template can optionally be specified for field level 

mapping during the copy, but it is not needed for a typical file copy.) 
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d. On the Additional Options screen, click Next.   
• (Note:  Initial position can be specified with Skip records or VSAM key.) 

 

e. On the Advanced Options screen, click Finish.   

• (Note:  Record sampling options provide a way to copy only periodic subsets of records.) 
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f. If the copy completed, a message is displayed indicating success.   

• Click OK To clear the message. 

 

g. The new data set is displayed in a data set list, if the name matches one of your queries. 

 

2. You have completed this exercise. 
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Summary 
 

Congratulations, you have completed the exercises and have familiarized yourself with the File Manager eclipse 

interface. 

 

In this lab: 

• You displayed lists of files based on file name filters 

• You selected and opened a file in the editor  

• You used the file editor to navigate files and work with data and records 

• You used a template to select records in a file and to customize how the data in a file is displayed 

• You allocated a new z/OS file 

• You copied a z/OS file 

 

 

If you have any questions about File Manager, please contact the instructor. 
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