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Overview  

 

Fault Analyzer 

IBM® Fault Analyzer for z/OS® is a robust problem determination tool that helps you discover why an 
application abends. It can report information in terms of application code, which means that developers 
and maintainers are not forced to interpret a low level system dump or system-level error messages. As a 
result, the reason for the abend can be determined sooner and with less effort. 

When an application abend occurs, Fault Analyzer captures details about the failure and stores the 
information  into a Fault History file. It analyzes the information about the application and its 
environment in real time, then generates an analysis report detailing the cause of the failure.  

Some of the main features of Fault Analyzer are: 

• Automatic collection and analysis of application abend information 

• Source-level information (abending statement, variable values) for many languages including 
Enterprise COBOL, Enterprise PL/I, assembler and others. 

• Interfaces from either TSO or eclipse  
 

This workbook 

This workbook contains instructions for lab exercises that are designed to give you hands-on experience 
for the eclipse interface of IBM Fault Analyzer for z/OS. 

 

Reference 

Product manuals and other information about IBM Fault Analyzer for z/OS, and other IBM problem 
determination tools, are available on the Web at URL:  

http://www.ibm.com/software/awdtools/deployment    
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Lab Exercise 1 

Getting started with the Fault Analyzer perspective 

 

In this exercise you will: 

� Open the Fault Analyzer perspective in the Eclipse workbench. 

� Learn how to display help information for Fault Analyzer. 

 

1. Before you begin, you must have the Eclipse interface open on your workstation. If you aren’t sure how to 
open it, please contact your instructor. 

 

In eclipse, a perspective is a set of views (windows), menus, and options that provide a set of functions. The 
File Manager interface is a perspective. Before you can use File Manager, you need to open it’s perspective.   

 

2. Opening the Fault Analyzer perspective. 

a. From the menu bar near the top of the eclipse workbench, select Window > Open Perspective > Fault 
Analyzer. 
i. Note: If “Fault Analyzer” is not shown as a selection, then the Fault Analyzer perspective is already 

open and you can proceed to the next step. 
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3. The Fault Analyzer perspective is displayed. Note: the contents of the Systems Information view may be 
different or even blank on your system. 

 

4. Notice that there are several views (windows) in the Fault Analyzer perspective. By default, the Systems 
Information view is displayed in the upper left. In the next exercise, you will use this view to work with 
abends that Fault Analyzer has collected on a z/OS system. From the Systems Information view, you can 
initiate actions including: 

• Select a z/OS system to be accessed 

• Specify the name of a fault history file 

• Open a fault history file 

• and other actions 

5. You can display help information to assist with various features of Fault Analyzer.  

a. To open the help dialog, select Help > Help Contents. 

 
 

b. The Help dialog is displayed. To expand the Fault Analyzer help topics, click the plus ( + ) next to IBM 
Fault Analyzer for z/OS User’s Guide. 
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c. Under IBM Fault Analyzer for z/OS User’s Guide, select Concepts > History Files and Views. 

 
 

d. The selected topic is displayed. 

e. Now you have seen how to display general help information.  

f. Close the help dialog: click the X (close) icon in the upper right corner of the help window. 

6. You can also display a list of keyboard commands.  

a. In the eclipse workbench Select Help >  Key Assist. 
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b. A list of keyboard commands is displayed. 

 
 

7. Note: As you work through the exercises, you may accidentally close or hide a view (a window) or other 
parts of the Fault Analyzer perspective. Remember that if that happens, you can easily reset the perspective 
to its default views. Try it now, so you know how to perform the reset: 

• From the menu, select Window > Reset perspective. 

• The perspective is reset. The default views are displayed in their default positions and with their 
default sizes.   

8. Now that the Fault Analyzer perspective is open, and you know where to find help, you are ready to start 
using Fault Analyzer in the following exercises. 
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Lab Exercise 2 

Displaying a list of abends in a Fault History File, and displaying an 

abend report  

 

In this exercise you will: 

� Determine if a fault history file has been added, and add a new fault history file if required. 

� Become familiar with working with fault history files and fault entries. 

 
Introduction to Fault History Files 

When a running program abends on a z/OS system, Fault Analyzer can capture information about the abend. 

The captured information is stored in a special file called ‘fault history’ file. Information for one abend is 

called a ‘fault entry’. A fault history file can hold more than fault entry.  

A system can have one or more fault history files. The name or names of the history files are controlled by 

the system administrator of Fault Analyzer. If there are multiple fault history file on a system, the 

administrator configures Fault Analyzer to select the correct fault history file to capture each fault entry. 

Characteristics such as the job name, user id, job or transaction type, program name and other things can be 

used to control which fault history file is used to collect each abend.  

For this exercise, you were provided the name of a history file that you will use. If you are not sure about 

the name of the history file to use in this exercise, please ask for the name of the file. 

 

1. In the Systems Information Tab, under the z/OS system that you will use during this exercise, select Fault 
Analyzer for z/OS > Browse History files 

 

 

2. See if the history file name that you will use for this exercise is already shown. If it is then skip down to step 
4 (you do not need to do step 3). 
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3. You can add a definition for a fault history file.  

a. Right-click Fault Analyzer for z/OS, and select Add History File  

 

 

b. Enter the full history file name without quotation marks. Use the history file name that was provided to 
you for this exercise. DO NOT use the name of the history file shown in this example, unless it is the 
same as the name provided.  

 

 

c. The history file is displayed in the list. After a history file is in the list, you are ready to work with it. 
Proceed to the next step.   
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4. Working with a history file. 

a. To open a history file, Double-click its name.  

b. The list of fault entries in the history file is displayed in a separate view. 

             

 

 
Tip: If Fault Analyzer has captured new abends since you opened a fault history file, you can refresh it. In the 

Systems Information view, right-click the Fault History file and select Reload history file from host.   

5. You have completed this exercise.  

 
 

  



 

____________________________________________________________________________________ 

Page 10  IBM Fault Analyzer for z/OS lab exercises 

Lab Exercise 3 

Researching an example abend report  
 

In this exercise you will: 

� Learn to navigate an analysis report, and understand what information presented is presented in the 
various sections of an a report 

� Research an example abend to determine why the application abended 
 
 

1. If the fault history file is already open, and a list of fault entries is displayed, continue with this exercise. If a 
list of fault entries is not displayed, complete exercise 2 (to open a history file) before continuing.  

2. You can open a fault entry from the list.  

a. In the list of abends, double-click the example abend. You were provided the fault id of the sample 
fault entry that you will use in this exercise. If you are not sure which one to use, please ask. 

             

 

b. The abend report is displayed  
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3. Next you will get practice navigating the sections of the abend report. 

a. Notice and use the scroll bar on the right to scroll the report up and down.      

            
   

b. Notice the tabs at the bottom of the report. Each tab can be clicked to display a different part of the 
abend report. 

       
 

c. Click the Main Report tab. 

 
   

 

• The main report shows a synopsis of the abend.  It contains information including the abend code 
and the name of the program that was running when the abend occurred. If source mapping 
information was available, Fault Analyzer reports the specific statement in the program that was 
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executing when the abend occurred. Scroll down to see the abending statement and the fields 
referenced by the abending statement and their values. 

 

d. Click the Event Details tab. 

 

        

• The top part of Event Detail report is the Event Summary, which shows the programs in the call 
chain. You can scroll down to see detailed reports for each program in the call chain. 

e. Click the Abend Information tab 

 
 

• The Abend Information report tab displays general information about the abending job and 
programs. 

f. Click the System-Wide Information tab 
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• The System-Wide Information Tab displays information captured about the abend that is not 
associated with a specific program.  

g. Click the Miscellaneous tab 

 
 
 

• The Miscellaneous Tab displays information about Fault Analyzer options and datasets used by 
Fault Analyzer as it analyzed and stored the report.  

 

4. A view (a window in the workbench) can be maximized to full size to provide a larger area. 

• Double-click the tab of the abend report view to expand it to the full size of the workbench. 

       
        

• Double-click the tab again, and the view is restored to its previous size. 

• Remember that you can maximize a view in the workbench if it will be helpful to make it larger. 

5. Note: In the following steps, the example abend will be analyzed to determine the reason why the abend 
occurred. 

6. You can determine high-level information about an abend. For example, did the abend occur in a batch job, 
a CICS transaction, or some other environment? When did it occur? What program abended? If you are not 
familiar with an application, it can be helpful to use the reports to get information that can help you 
understand the application and the environment. 

• Click the Abend Information tab         
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• This report shows that the application was running as a batch job. Notice that the job name, the 

date and time, the name of the system where the job was running, and other high level 
information is displayed. Scroll down to see the rest of the report.     

• For the purposes of analyzing this sample application, all that you need to notice here is that it is 
a batch job, and the name of the main program (the ‘EXEC Program name’) is SAM1.   

7. Click the Main Report tab. 

 

 

a. In this example the job failed with a S0C7 abend code, while running in program SAM2 at source line 
89.  Scroll down to display the abending statement, variables and variable contents. 
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b. Notice that a brief explanation is given for ‘S0C7’ abend code. The report describes it as ‘A decimal 
digit or sign was invalid.’ The report shows that the program was attempting to execute a COMPUTE 
statement when it failed. It also shows that variable CUST-ACCT-BALANCE contained invalid 
numeric data.  

• You can determine from the report that the abend occurred because variable CUST-ACCT-
BALANCE had invalid data, and the program attempted to use it to perform a computation.  

c. Notice that certain text areas are underlined. These are links, and clicking them will display related 
information. For example, the ‘89’ and ‘S0C7’ near the top of the report are links. 

• Click the S0C7 link. 

   
• A lookup view is displayed, showing a detailed description of the system 0C7 abend code. 
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• Click the 89 link. 

• The source view is displayed, positioned at line 89, which is the abending statement. 

 
 

8. By default, the source view opens in the same pane as the report. Return to the report by clicking its tab. 

9. Next, you will continue to research the abend by reviewing information about the call chain and details 
about the programs. 

a. Click the Event Details tab. 

 
b. The event summary is displayed near the top. It shows the call chain, which is the list of programs that 

were active at the time of the abend. The first program in the list is the main program, the second is the 
program called by the main program, and so on. This report shows three events in the call chain. 
Program SAM1 is the main program. It called a system routine called IGZCPAC, which in turn called a 
program called SAM2. The abend occurred in SAM2. 

10. Note: The event details section also provides detail reports for each program in the event summary (the call 
chain). There are two ways to scroll to the detail report for a program. One way is to simply scroll down 
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using the scroll bar on the right. The other way is to click one of the links in the ‘Event #’ column 
(numbered 1, 2 and 3 in this example) of the event summary list.  

11. Scroll down to the detail report for event 1. This is the detail report for the first program in the call chain, 
SAM1.   

  
a. Additional information is displayed about the program as you scroll down 

i. The paragraph trace shows the paragraphs that were executed to get to the current statement. Notice 
that the line numbers are links. 

  
 

ii. The current statement, and the variables that it references are displayed. 
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iii. Information about the module is shown, including the name of the load library where the program 
module resides, the compile date and time, and other details. 

 

 
iv. The machine instruction that was executing when the abend occurred is shown with its address, 

followed by the values of the general purpose registers. 

 
 

v. Further down in the report is the ‘Associated Open Files’. Each file that was open to this program at 
the time of the abend is reported. One of the open files has a DD name of CUSTFILE. It’s file name 
and how it was opened (‘INPUT’ in this example) are shown. Also notice that the contents of the 
record buffers are displayed. 

 
 

vi. Scroll down until you reach ‘Associated Storage Areas’. Notice that all variables in the program are 
displayed. Their values are shown both as a value and in hexadecimal. 
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12. Next, you will display the detail report for the abending program: 

a. Scroll to the top, and click event 3 (the abending program). 

 
 

b. The report is positioned to ‘Event 3 of 3’. This part of the report is the detail report for the third event, 
which is program SAM2. 

13. Previously, you saw that program SAM2 abended because there was invalid data in a variable named 
CUST-ACCT-BALANCE. To research this abend, it will be helpful to determine how bad data got into that 
variable. Next, you will track the data back to its source. 

a. When researching an abend caused by invalid data, sometimes it is helpful to examine information 
about the variable in the ‘Associated Storage Areas’ section. An easy way to scroll to the variable is to 
search for it in the report: 

• Press the CTRL+F keys.  

• The Find/Replace dialog is displayed. 

♦ Tip: You can also display the Find/Replace dialog by selecting Edit > Find/Replace from the 
menu.  

• Type CUST-ACCT-BALANCE in the ‘Find’ field, and click the Find button. 
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• The report is positioned to the next place that contains the text ‘CUST-ACCT-BALANCE’.  

 
• Click the Find button a few more times, until you find the variable in the part of the report where 

all of the variables in the program are displayed (the Associated Storage Areas). 

 
• Although the variable is defined as numeric, the value (‘@#$%&’) is not numeric. 

• Notice that the variable is part of a group variable named CUST-REC. Also notice that it is in 
linkage section. The abending program, SAM2, is a called program. In COBOL programs, data 
is passed to called programs in linkage section. The fact that the variable is in linkage section 
means that the data was possibly passed from the main program SAM1. 

14. Next, to track the data back to its source, you will look at the data passed by the main program. 

a. Scroll to the top, and select event 1 (the main program, called SAM1). 

 
b. The report is positioned to event 1 of 3. 
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c. Scroll down to the current statement. Notice it is a CALL statement and that it is passing a variable 
called CUST-REC. 

d. Scroll down to the Associated Storage Areas, and locate the CUST-REC variable. Tip: you can press 
Ctrl+F again to open the Find dialog and search for the variable name.  

 
e. Notice that the bad data (‘@#$%&’) has been traced back to the calling program. Also notice it is in 

File Section, which indicates that the data may have been read from a file. The DD name of the file is 
CUSTFILE. 

15. Next, look at the file record buffer to see if the invalid data was read from the file. 

a. Scroll up to the ‘Associated open files’ section and notice the information for the CUSTFILE file. 
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b. Notice that CUSTFILE is an input-only file, and that the bad data (‘@#$%&’) can be seen in the record 
buffer. 

16. At this point, there can be a conclusion about why this abend occurred. Based on the information in the 
report, the sequence of events that led up to the abend can be determined: 

a. The main program, SAM1 read a record from the CUSTFILE file. The file contained bad data in the 
CUST-ACCT-BALANCE field. 

b. Program SAM1 called program SAM2 and passed the record to it.  

c. A statement in program SAM2 attempted to perform a calculation using the invalid data, which caused 
it to fail with a S0C7 abend code. 

17. In a real scenario, you might take actions such as fixing the data in the file. Another possible action would 
be to modify the program so that it would validate numeric data in the file before attempting to perform 
calculations. 

18. You have completed this exercise.  
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Lab Exercise 4 

Working with the list of fault entries  
 

In this exercise you will: 

� Learn to work with the list of fault entries 

� Customize the list of fault entries 
 
 

1. If the fault history file is already open, and a list of fault entries is displayed, continue with this exercise. If a 
list of fault entries is not displayed, open the history file. If you are not sure how, complete exercise 2 before 
continuing.  

2. In the previous exercise, you saw that double-clicking a fault entry will open the analysis report. In addition, 
there are actions you can take such as sorting and filtering the list, and customizing the columns shown. 

3. You can sort the list.  

a. Click the JOB/TRAN column heading.  

b. The entries are sorted based on JOB/TRAN in ascending order. 

 
 

c. Sort the list again on the Fault ID column. Click the FAULT_ID column heading. The entries are 
sorted based on the fault id. 
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4. You can filter the list to display only selected entries. For example, you can add a filter to display only S0C7 
abends:   

a. Right Click anywhere in the fault list, then select Filters > ABEND.  

 
 

b. Enter S0C7 in the field and click OK.  You must use capital letters to get a match. 

• Tip: you can use wildcard characters  *  and  %  in the filter. 

 
 

c. Only entries with a S0C7 abend code are displayed. 

 
 

d. You can Remove the filter to display all abends again.  

• Right Click anywhere in the fault list, then select Filters > ABEND.   

• Delete the filter text, then click OK. 



 

____________________________________________________________________________________ 

Page 25  IBM Fault Analyzer for z/OS lab exercises 

       
 

e. The list is displayed showing all entries. 

5. You can add and remove columns. Next you will add column ‘CICS_TRN’ to the list. 

a.  Right Click anywhere in the fault list, then select Columns. 

b. Notice that there is a check mark next to each column that is selected. 

c. Click CICS_TRN.   

 
 

d. The CICS_TRN column now appears in the list of fault entries. 

 
 

e. You can remove a column.   

• Right Click anywhere in the fault list, select Columns.  

• Notice that CICS_TRN is checked now. 

• Click CICS_TRN.   

• The list is re-displayed, and the CICS_TRN column is removed. 

 



 

____________________________________________________________________________________ 

Page 26  IBM Fault Analyzer for z/OS lab exercises 

 

6. You can drag and drop a column heading to move the column. 

a. Drag and drop the JOBNAME column header to make it the second column (after Fault_ID). 
(Specifically, click-and-hold the word ‘JOBNAME’, drag the mouse pointer over until it is just to the 
right of the word ‘FAULT_ID’ in the column heading, then release the mouse button.)  

 

 
 

b. The new column configuration will be displayed with JOBNAME after FAULT_ID. 

 
c. Drag and drop JOBNAME column back to where it was, to the right of JOB_ID. 

7. You can create a customized column profile.  

a. Right Click anywhere in the fault list, and select Configurations > Manage configurations. 

 
b. The ‘Manage column configurations’ dialog is displayed. 

c. Click the Add button. 

 
 

d. Enter a name for the new configuration (for example, you can use your own name). Click OK. 
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e. Next you will select the columns that you want in your configuration.  

• Click the check box next to all of the column names that you want. (You can select any set of 
columns). 

• Notice that you can move columns up and down with the Up and Down buttons. 

• When the columns you want are selected and in the order you want, click OK.   

  
 

f. When prompted to save the new configuration, click YES. 

 
 

8. Next you will activate the new configuration. 

a. Right Click anywhere in the fault list, then click Configurations then click the name of the new 
configuration. 
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b. The columns are displayed according to the new configuration. Note that this configuration will be used 
by default the next time you use Fault Analyzer in this eclipse workbench. 

9. You have completed this exercise.  
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Summary 
 
Congratulations, you have completed the exercises and have familiarized yourself with the Fault Analyzer 
eclipse interface. 
 
In this lab: 

• You displayed a list of abends in a Fault History file 

• You viewed an abend report 

• You researched an abend to determine the cause of the failure 

• You saw how the abend list can be customized 
 
 
If you have any questions about Fault Analyzer, please contact the instructor. 
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