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Overview  

 

Debug Tool 

Debug Tool is a single tool you use to debug application programs across z/OS environments, including 

batch, CICS, IMS, TSO, DB2 compiled stored procedures, Unix System Services, about anywhere an 

application program can run on a z/OS system. 

It is an interactive debugger, and has the features you need to step through a program, set breakpoints, and 

monitor and change variables. It also has powerful debugging features, including automation with scripts, 

playback, statement tracing and more. 

Debug Tool can be accessed using a 3270 terminal interface. There is also an eclipse GUI interface that is 

available in the PD Tools Studio, and will also run in RDz, z/OS Explorer and CICS Explorer. 

 

This workbook 

This workbook contains instructions for lab exercises that are designed to give you hands-on experience 

for the eclipse interface of IBM Debug Tool for z/OS. 

 

Reference 

Product manuals and other information about IBM Debug Tool for z/OS, and the other IBM problem 

determination tools are available on the Web at URL:  

http://www.ibm.com/software/awdtools/deployment    
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Lab Exercise 1 

Getting started with the Debug Tool perspective 

 

In this exercise you will: 

� Open the Debug Tool perspective in the Eclipse workbench. 

� Learn how to display help information for Debug Tool. 

 

 

1. Before you begin, you must have the Eclipse interface open on your workstation. If you aren’t sure 

how to open it, please contact your instructor. 

 

In eclipse, a perspective is a set of views (windows), menus, and options that provide a set of functions. 

The Debug Tool interface is a perspective. Before you can use Debug Tool, you need to open its 

perspective.   

 

2. Opening the Debug Tool perspective. 

a. From the menu bar near the top of the eclipse workbench, select Window > Open Perspective > 

Debug. 

• Notes:  

� Depending on your eclipse workbench, you need to select Window > Open Perspective 

> Other > Debug. 

� If “Debug Tool” isn’t shown as a selection, then the Debug Tool perspective may 

already be open, and you can proceed to the next step. 
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b. The Debug Tool perspective is displayed. Note that the default configuration of the views may be 

different on your system. 

 

 

c. Notice that there are several views (windows) in the Debug Tool perspective. By default, the 

Debug view is displayed in the upper left.  

d. You can display help information to assist with various features of Debug Tool. To open the help 

dialog, select Help > Help Contents. 

 

e. The help dialog is displayed. 
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f. To expand the Debug Tool help topics, click the plus ( + ) next to ‘Compiled language debugger’. 

 

 

g. Under Compiled Language Debugger, select Compiled Language Debugger > Getting started 

debugging a z/OS application with the debugger. 

  

 

h. The selected topic is displayed. 

i. Now you have seen how to display general help information. Close the help dialog: click the X 

(close) icon in the upper right corner of the window. 
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j. You can also display a list of keyboard commands. In the eclipse workbench Select Help >  Key 

Assist. 

 
 

k. A list of keyboard commands is displayed. 

 

 

l. Now that the Debug Tool perspective is open, and you know where to find help, you are ready to 

start using Debug Tool in the following exercises. 
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Lab Exercise 2 

Submitting an example batch application and starting the debugger 

 

In this exercise you will: 

� Use tools in the Debug Tool perspective to determine the IP address of your workstation 

� Edit JCL that will be used to submit a batch job to run an example application 

� Code a ‘TEST’ option in the JCL that will start the debugger when the job runs 

� Submit the job and start the debugger 

 

 

Introduction to starting the debugger with a batch application 

Debug Tool can be used to debug applications running in various environments on a z/OS system, 

including batch jobs, TSO, CICS transactions, IMS/TM transactions, DB2 external stored procedures, 

USS and other environments. 

In this exercise, you will submit JCL to run an example batch application on a z/OS system. Before 

submitting the job, you will code a special ‘TEST’ option in the JCL. TEST causes a system feature 

called Language Environment to trigger the debugger when the job runs. When the debugger starts, it 

displays in your eclipse workbench. You can then use the debugger in eclipse to control and examine 

the application as it runs as a batch job on a z/OS system. 

This is the general process you will perform: 

1) In the Debug Tool eclipse perspective: 

a. turn on the Debug Tool IP listener 

b. determine the IP address of your workstation, and the Debug Tool listener IP port 

number 

2) In TSO (or other development environment): 

a. edit and prepare JCL to run a provided sample application 

b. code a special ‘CEEOPTS’ DD in the JCL with a certain ‘TEST’ option. The IP 

address and listener port are coded as parameters of the TEST option, so the debugger 

knows where to connect. 

3) Submit the JCL to run the sample application as a batch job on a z/OS system. 

4) When the job runs, Debug Tool is triggered, and appears in the eclipse interface automatically.  
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1. First you will start the Debug Tool listener, and determine the IP address of your workstation. 

a. Determine if the Debug Perspective is already open. If the ‘Debug’ view is displayed, then the 

Debug perspective is already open. 

b. If it is not already open, open it: 
• From the menu near the top of the eclipse workbench, select Window > Open Perspective 

> Debug. 

c. The Debug perspective is open. 

 
 

• Note: Another way to open the Debug Perspective is to click the ‘Open Perspective’ icon 

and then select Debug. 

 

 

d. Note: Debug Tool listens for your job to talk to the Debug Perspective.  The Debug Tool listener 
must be on.   
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a. Ensure that the listener is on (green). 

• If the listener icon is red, then click it to turn it green. 

 
 

• Ensure that the listener icon is green before continuing. 

 

b. Next, note the Workstation IP address, and the listener port number.   

i. Click the small, black triangle next to the green listener icon.  

ii. The port is shown on the line: ‘Debug UI daemon is listening on port ….’.  

• Make a note of the port number.    

iii. Click Get Workstation IP..   

 
 

iv. Make a note of the IP address. This is your workstation’s network address. 

 
• Tip:  You can copy the Workstation IP address by right-clicking the address, then selecting 

Copy. 
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2. Next, you will connect to a z/OS host system so you can edit JCL and submit a job. 

a. Double-click the icon on the desktop called MOP Brown 3270 

 

b. A 3270 terminal window opens. Log on with the User ID and password you were provided. 

• Note: the ‘Enter’ key may be mapped to the right Ctrl key on your keyboard. 

c. After logging on, from the main menu, select option 2 (edit). 

 
 

d. The Edit Entry Panel is displayed. Next you will edit JCL that has been prepared for you. 
• Specify file name: your-id.ADLAB.JCL and member name XSAM. 

• Use the User ID that you were provided as the first qualifier. 
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e. The JCL in your-id.ADLAB.JCL(XSAM) is displayed in the editor. 

3. Customize the JCL. 

a. Only one change is needed in the JCL: you must update the IP address coded in the TEST option. 

• Locate the CEEOPTS DD statement.  

• There is a TEST option just below it. The IP address is coded in the TEST string after the 

& (ampersand) and before the % (percent). 

• In an earlier step, you noted the IP address of your workstation. Replace the IP address in 

the TEST option with your IP address. 

� For example, if your IP address were 11.22.33.44, then you would code the CEEOPTS 

DD and TEST option like this: 
  //CEEOPTS  DD  * 

  TEST(,,,TCPIP&11.22.33.44%8001:) 

• After updating the JCL with your IP address, you are ready to submit it. 

 

4. Submit the job. 

a. Type SUBMIT on the command line, and press Enter.   
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5. When the job runs, Debug Tool will automatically attempt to connect to your session. 

a. If the PD Tools Studio is not on top, click it’s icon to select it. 

b. If you receive this’Confirm Perspective Switch’ message, click Yes. 

 
 

c. The debugger is displayed, and the source of the program is shown. 

 

d. If the debugger doesn’t start, then … 

• Verify that the IP address and port are correct.   

• Ensure that the syntax of the TEST option is correct, based on the examples.  

 

e. If Debug Tool does not start, please ask for assistance. 

 

6. After you have a Debug Tool session running, you are ready to proceed to the next Lab Exercise 
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Lab Exercise 3 

Using the Debug Tool graphical user interface 

 

1. Note: Before you do this exercise, you must first start a Debug Tool session by running sample 

program SAM1. If you do not already have a debug session started and you are not sure how to start 

it, return to the previous exercise, which describes how to start a debug session. 

2. Note: Here are some things to remember during this exercise: 

a. If your debugging session ends, you can re-submit the job that you ran in the previous exercise to 

start a new session. 

b. You may notice that the example application will abend at a certain statement. Be aware that this 

is built into the example, and is expected. If you reach the abend, you can terminate the debugging 

session by clicking the Terminate button (the icon that looks like a red box) in the Tool Bar and 

then re-submit the job from the previous exercise. 

3. Note: The Debug perspective is composed of several views (windows). You can customize the 

perspective by re-arranging the views or adjusting their sizes.  

 
 

  

Debug view 

Source view 

   Variable, Breakpoint, Monitor views 
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a. You will work with several of the views during this exercise. As an introduction, here is a brief 

description of the views that are used the most: 

i. The Source view displays and lets you work with the program that is being debugged. The 

current statement is highlighted. In the above example it is the blue line. 

ii. The Debug view shows the current call chain, from the main program to the current program. 

iii. The Monitor view is used to monitor variables. If you add a variable to the monitor view, you 

can watch it change as you step through the program. 

iv. The Variables view can be used to auto-monitor variables, so that variables referenced by each 

statement are displayed automatically as you step through the program. 

v. The Breakpoints view displays and lets you work with breakpoints. 
vi. The Console view lets you to enter commands to the Debug Tool engine. If you are familiar 

with the Debug Tool 3270 terminal interface, many of the same commands can be entered 

here. 

4. A view can be maximized. For example, maximize the source view:    

a. Double-click the tab of the source view. 

 

b. The source view is maximized to the full eclipse workbench window. 

c. Double-click the tab of the source view again. 

 



 

____________________________________________________________________________________ 

Page 15  IBM Debug Tool for z/OS lab exercises 

d. It is returned to its previous size. Most views can be maximized. It can sometimes be helpful to 

maximize a view to provide more room to work with its contents. 

5. Notice that the tool bar near the top has several action buttons. 

a. You can hover over a button to determine what it does. 

• Hold your cursor, WITHOUT clicking, over the Step Into button (one of the yellow arrow 

icons). 

• Notice that a pop-up description is displayed, in this case: ‘Step Into (F5)’. The (F5) 

indicates that pressing the F5 key will perform the same action as clicking the button. Use 

this hover feature when you are looking for a button. 

 

6. You can step through statements in a program one at a time. 

a. Click the Step Into button. 

 

b. Notice that the highlighted line in the source window moved. 

• Note: ‘Step Into’ is the button typically used to step through a program. 

c. Press the F5 key. 

• Notice that F5 is the same as ‘Step Into’. You can use which ever you prefer, either the 

button or the key. 

d. Continue to step through the program until reaching statement 252. (It is OK if you step a few 

statements beyond). 

 

7. You can search for text in the source window. 

Right-click anywhere in the Source view, then select Find Text. 
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a. In the Find Text panel type CURRENT-MINUTE in the Search string field, then click OK. 

 

b. The program is positioned to the next occurrence of CURRENT-MINUTE with the text 

highlighted. 

 
 

c. Tip: Pressing  Ctrl-F will also open the Find Text dialog.  

 

8. You can easily set a breakpoint at a statement and run the program until it reaches the breakpoint. 

a. Set a breakpoint on line 258: 

• Double-click in the blank area to the left of statement 258. 

 

b. A breakpoint icon is displayed. 

 
 

c. Click the RESUME button (green triangle) in the Tool Bar.   
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d. The program ran, continuing from where it already was, until it reached statement 258. Because of 

the breakpoint, execution is paused at 258. Statement 258 has not yet executed. 

 
• Tip:  If you prefer, you can use the F8 key instead of the Resume button (but don’t do it 

right now). 

• Note: ‘Resume’ runs the program, continuing from its current location. The program will 

continue to run until it encounters a Breakpoint, encounters a condition (such as an abend), 

or completes.   

 

e. The breakpoint can be removed: 

• Double-click the breakpoint icon on statement 258. 

 
• Notice that the breakpoint is removed.  

 

9. In the previous steps, you set a breakpoint and then ran the program until it reached it. However, there 

is another way to run to a particular statement and you do not even have to set a breakpoint first: the 

‘Run To Location’ function. 

a. Scroll the Source until line 310 is displayed. 

b. Click on line 310 to select it. 

c. Right-click line 310, then select Run To Location. 
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d. The program ran, continuing from where it was, until it reached statement 310. Execution is 

paused at 310. Statement 310 has not yet executed. 

• Note: ‘Run To Location’ runs the program, continuing from its current location. The 

program will continue to run until it reaches the Run-To statement, or encounters a 

Breakpoint, or encounters a condition (such as an abend), or completes.   

 

10. You can also work with breakpoints from the breakpoints view. 

a. Note: You can use the breakpoints view to display, create, modify and remove breakpoints. 

Breakpoints can also be temporarily enabled and disabled.   

b. Double-click next to line 310 to set a breakpoint there. 

 

 

c. Click the tab of the Breakpoints view .   

 

 

d. Notice that it displays a list of breakpoints. 
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11. Breakpoints can also be created in the Breakpoint view.   

a. Right-click in the Breakpoints view, then select Add Breakpoint > Statement.   

 

b. In the ‘Add a Statement Breakpoint’ dialog, type 309 in the Statement field, then click Finish. 

 
 

12. Notice that a breakpoint was added at statement 309. 
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13. You can also remove a breakpoint from the Breakpoints view. 

a. Right-click the breakpoint for line 310, then select Remove. 

 

b. Notice that the breakpoint is removed. 

• Tip:  You can also select and then click the ‘Remove breakpoint’ icon in the Breakpoint 

view tool bar to remove a breakpoint. 

 

14. Note: there are many ways to display and work with variables in the debugger. In the next steps, you 

will become familiar with the hover feature, the Variables view and the Monitors views. 

15. The hover feature provides an easy way to display the value of a variable.  

a. Scroll the source window (if necessary) to display line 310. Notice that statement 310 references 

the NUM-CUSTOMER-RECS variable. 

b. Hold your cursor, WITHOUT clicking, over the NUM-CUSTOMER-RECS variable on line 310. 

c. Notice that the value of the variable is displayed in a pop-up window. 

 
• Tip: hovering in the Source window is a quick and easy way to display variable values. 
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16. The Variables view provides additional ways to display variable values. 

a. Click the tab of the Variables view to display it (in case it is not already on top).  

 
 

b. Note: the variables view can be used to automatically monitor the values of referenced variables as 

you step through a program. 

c. Turn on the Automonitor filters: 

• Right-click any variable in the Variables view, then select Filter Locals. 

• Notice that there are selections for ‘Automonitor Current’ and Automonitor Previous’. If 

either of them is not selected with a check mark, click it to select it. 

 
• If necessary, repeat until ‘Automonitor Current and ‘Automonitor Previous’ are both 

selected. 
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d. Click the Step Into button.  

 
• Notice the current statement in the source window. The variables referenced by the current 

statement are automatically displayed in the Variables view. 

e. Click the Step Into button several times again.  

• Another statement is reached. Notice that variables referenced by the new current 

statement are displayed automatically in the Variables view. 

• The ‘Automonitor Current’ filter displays variables for the current statement. 

• The Automonitor Previous’ filter displays variables for the previously displayed statement, 

so that you can automatically see changes made to variables as you step. 

 

f. Tip: You can display an item in the Variables view in hexadecimal display by right-clicking it, 

then selecting Change representation > Hexadecimal. 

 

17. Notice that as you stepped, the application stepped into a subprogram called SAM2.  

a. Continue to step (using the Step Into button, or the F5 key) until the application returns back to the 

calling program SAM1. 

b. Note: It will take approximately 20 or 30 steps until it reaches the GOBACK statement on line 82 

and returns.  

18. The Monitors view provides the ability to add variables permanently to the display.  Different from 

the Variables view, an item added to the Monitors view remains visible until it is removed.   

a. Ensure that you have stepped back to program SAM1. 

b. Scroll the source window until line 315 is displayed. 

c. On line 315, double-click the variable CUST-NAME  to select it, then right-click it, then select 

Monitor Expression. 
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d. Click the tab of the Monitors view. 

e. Notice that CUST-NAME is added to the Monitors view and its current value is displayed. 

19. You can change the value of a variable. 

a.  Double-click the area containing the data. 

 

b. Overtype the data. Make up a name and enter it into the CUST-NAME variable, then press Enter. 

• Hint: since it is a character field, the single quotation marks are required. 

 

c. The value of the variable is changed. 

20. You may prefer to have both the Monitors view and Variables view visible at the same time.  This is 

possible because the locations and sizes of views can be rearranged. 

a. Click and hold the tab of the Monitors view.  Drag it to one side or the other until a green outline 

of the view appears where you want it. Release the view at a desired location.  

 

 

b. The Monitor view was moved, and the Variables view and Monitors view can both be displayed: 
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c. Hint: If the views accidentally get rearranged in an undesirable way, remember that selecting 

Window > Reset perspective will return all views to their default locations. 

 

21. You can make breakpoints conditional. 

a. Remove all existing breakpoints: 

• In the Breakpoints view Click the Remove all Breakpoints icon. 

  
• A confirmation dialogue is displayed.  

�  Click YES . 

• Notice that all breakpoints are removed. 

b. Add variable CUST-ID to the Monitor view: 

• Scroll to line 314.   

• Double-click variable CUST-ID to highlight it, then right-click it, then select Monitor 

Expression. 

c. Next, add a conditional breakpoint: 

• Right-click in the Breakpoints view, then select Add Breakpoint > Statement. 

d. In the ‘Add a Statement Breakpoint’ dialog, type 404 in the statement field, then click Next. 
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e. In the Expression field area type CUST-ID=’11004’, then click Finish. 

 
 

• Note: This breakpoint will check the condition each time the program reaches statement 

404. If the condition is true, then the program will be paused at 404. 

f. The new breakpoint appears in the Breakpoints view. 

g. Click the RESUME button in the tool bar.   

 

 

h. The program is paused at statement 404. Notice in the Monitors view that the value of CUST-ID is 

‘11004’. The breakpoint triggered only when 404 was reached and the condition was true. 

 

22. Note: So far in the exercise, you have only used statement breakpoints. Next, you will add a watch 

breakpoint. A watch breakpoint pauses the program when a named variable changes, instead of at a 

specific statement.   

 

a. In the Breakpoints view, remove all breakpoints: 

• Click the Remove all Breakpoints icon. 

  
• A confirmation dialogue is displayed.  

�  Click YES . 

• Notice that all breakpoints are removed. 
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b. Add variable NUM-CUSTFILE-RECS to the Monitor view: 

• Right-click in the Monitors view, then select Monitor Expression. 

 
 

• Type  NUM-CUSTFILE-RECS then click OK. 

 
 

• NUM-CUSTFILE-RECS appears in the Monitor view.  Notice its current value. 

 
 

c. In the Breakpoints view, right-click then select Add Breakpoint > Watch. 
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d. In the ‘Add a Watch Breakpoint’ dialog, type NUM-CUSTFILE-RECS  in the Address or 

expression field, then click Finish. 

 
 

e. The breakpoint was added. 

f. Click the RESUME button in the Tool Bar.   

 

 

g. The watch breakpoint paused the program after the statement that caused it to change executed. 

Notice in the Monitors view that the value of NUM-CUSTFILE-RECS has changed.  

h. Tip: You can make a watch breakpoint conditional if you only want the program to stop when the 

variable is changed to a certain value. 

 

23. Note: You can use the debugger to easily follow program logic into and out of subprograms. One 

simple method is to simply step into a called program. 

a. Run to statement 312: 

• Click statement 312 in the source view to select it. 

• Then right-click statement 312 in the source view, then select Run To Location. 
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b. Notice that line 312 is a CALL statement that will execute a subprogram named SAM2. 

 

 

c. Click the Step Into button. 

 

 

d. Notice that the debugger stepped into the subprogram, SAM2. Using ‘Step into’ at a CALL 

statement is one method you can use to follow program logic into a subprogram.  

e. Click Step Into a few more times to get a few lines deeper into SAM2. 

f. Note: An easy way to run to the completion of the subprogram is ‘Step Return’. 

g. Click the Step Return button in the tool bar. 

 

 

h. Notice that the application ran until it returned to the calling program. The source window is 

positioned back in the main program, on the statement after the CALL to SAM2. 

• Note: ‘Step Return’ runs the current subprogram to completion, and pauses the debugger 

after control has been returned to the calling program. 

 

 

24. Instead of stepping into subprograms, a quicker way to run until reaching a specific subprogram is to 

use an ‘entry’ breakpoint. 

a. Note: The SAM1 application calls SAM2 several times. Next, you will create an Entry breakpoint 

that will pause the next time program SAM2 is entered. 

b. First, remove all existing breakpoints: 
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• Click the Remove All Breakpoints button in the breakpoints view, then click Yes at the 

prompt. 

c. In the Breakpoints view, right-click and then select Add Breakpoint > Entry. 

 

d. In the  ‘Add an Entry Breakpoint’ dialog: 
• Click to select the option: Defer breakpoint until executable is loaded. 

• Type SAM2 into each of the three fields (Load Module/DLL/Executable, 

Object/Program/CSECT, and Function/Entry Point). These will fully qualify the Entry 

breakpoint.   

• Click Finish. 

 

e. The Entry Breakpoint was added, and appears in the Breakpoints view. 

f. Click the Resume button in the tool bar. 
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g. The application is paused at the beginning of SAM2. An Entry breakpoint provides an easy way to 

run the application until it reaches a specific program of interest. 

 
 

25. The Debug view can be used to display the source for different programs in the call chain (thread). 

a. Note: The application is currently running in the SAM2 program, and the source for SAM2 is 

displayed in the source window. 

b. Notice that the Debug view shows the current call chain. SAM1 is the main program, and SAM2 

is a subprogram. 

c. Click SAM1 in the Debug view. 

 

 

  



 

____________________________________________________________________________________ 

Page 31  IBM Debug Tool for z/OS lab exercises 

d. The source view displays SAM1, even though SAM2 is still the active program. 

 

 

e. Click SAM2 in the Debug view again to re-display SAM2 in the source view. 

• Note: The source view will re-display the active program automatically if you perform an 

action such as Step or Resume. 

 

26. To prevent stopping again the next time SAM2 is called, remove the Entry breakpoint for program 

SAM2: 

a. In the breakpoints view, click (to select) the Entry breakpoint for SAM2. 

b. Then click the Remove Selected Breakpoints button. 

c. Notice that the entry breakpoint for SAM2 is deleted. 

27. For the next step, SAM1 needs to be the active program. 

a. Click the Step Into button. 

b. If SAM2 is the active program (displayed in the Source window after a step), then click the Step 

return button now so the application will run until it returns to SAM1. 

28. You can use ‘Jump To Location’ to alter program flow.  

a. Note: ‘Jump To Location’ allows you to reposition the execution pointer (the blue line) to another 

statement in the program logic. You can do this if you want to skip over certain statements, or if 

you want to go back and re-execute a section of logic. Use this feature carefully – if you jump to a 

location that is not logical for your program, your program may attempt to do illogical things! 

b. First, run to statement 318: 

• Click statement 318 in the source view to select it. 

• Then right-click statement 318 in the source view, then select Run To Location. 

c. The program is paused at statement 318. 

d. Next, jump backward in the program to statement 314: 

• Click statement 314 in the source view to select it. 
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• Then right-click statement 314 in the source view, then select Jump To Location. 

 

e. Notice that the execution pointer (the long blue line) is repositioned to line 314. 

f. The next Step or Resume will continue execution from line 314. 

 

29. Ending the debug session. 

a. Note: There are four ways to terminate a debugging session (don’t do any of these yet): 

i. If the application runs to its normal completion, the debugger ends automatically when the 

application terminates itself. 

ii. The ‘Terminate’ button tells Debug Tool to immediately terminate the application with a zero 

return code, and also ends the current debugging session. 

• The Terminate button: 

 
iii. The ‘Disconnect’ button tells Debug Tool to end the debugging session, but allows the 

application to continue running on its own. 

• The Disconnect button: 

 
 

iv. The ‘Terminate and Abend’ action (available from the Debug view context menu > Options) 

tells Debug Tool to abend the application, and also ends the current debugging session. This 

can be a good option if you want to collect a dump or produce a report from Fault Analyzer, or 

if you want to initiate a rollback of updates to DB2 or IMS databases. 
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b. To terminate the debugging session and the application, click the Terminate button now: 

 

c. The application was terminated immediately, without running any more statements, with a zero 

return code.  

d. The Debug Tool session ended. 

 

e. The Debug Tool listener is still active, and it is ready to debug the next application. 
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Summary 
 

Congratulations, you have completed the exercises and have familiarized yourself with the Debug Tool 

eclipse interface. 

 

In this lab: 

• You started the debugger with a batch application 

• You learned how to set breakpoints, run to places of interest in a program, work with variables and 

other important debugging skills 

 

 

If you have any questions about Debug Tool, please contact the instructor. 
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