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This hands-on lab provides the opportunity to access IMS databases from a

distributed runtime environment provided by IBM’s IMS Enterprise Suite Explorer

for Development.  

This lab focuses on the use of the IMS Catalog , IMS 12  and IMS 13.

The IMS Enterprise Suite Explorer for Development

The IMS Enterprise Suite Explorer for Development is an Eclipse-based

integrated development environment (IDE) for IMS application developers

and database architects 

• It can also be integrated with other IBM Eclipsed based tools 

(RAD, RDz, Optim Data Studio) 

•  Provides end-to-end application development cycle 

•  Graphical editors are used for development and visualization of

•  Program Specification Blocks (PSBs)  

•  Database Descriptions (DBDs)
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 IMS Universal JDBC driver type-4 connectivity provides:

• Relational view of IMS data

• Graphical assistance to build SQL statements

• New support which incorporates the DLIModel Utility and the IMS 12 Catalog

functionality:

• Provides migration support of existing DLIModel Utility projects

• Provides Metadata source for update to IMS Catalog

• Provides Metadata access from the IMS Catalog 

 Distribution of the IMS Explorer is through a download capability 

IMS Enterprise Suite V3.1 at http://www.ibm.com/ims

IMS Connect and Open Database Manager  

• Open Database Manager (ODBM) is a Common Service Layer component

• Receives database connection requests from IMS Connect

• Translates incoming database requests from the DDM protocol into

DLI calls expected by IMS

• Translates responses to the client into the DDM protocol 

• Manages connections to IMS DB 

• Implements the DRA interface 
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IMS Enterprise Suite Explorer for Development

In this part of the lab, the IMS Explorer is used to create the IMS Java

Database View metadata by parsing the IMS PART Database PSB and

DBD sources. 

1. Start IMS Explorer

Click on Start > All Programs > IMS Enterprise Suite for Development >

IMS Enterprise Suite for Development 

                               

You may be prompted to select a workspace.  A workspace is a directory that

stores all of the files for the projects.  You can select your own directory, e.g.,

C:\share\explorerlab\workspace or any name you choose.     

                           

When Explorer startup is complete, you may be shown the Welcome

Screen.  If so, close the Welcome page (x the tab at the top of the screen

on the left).
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2.  Click on File > New > IMS Explorer Project.   (If you don’t see “IMS

Explorer Project” as a choice then click on File > New > Other and open

the IMS folder and select IMS Explorer Project)       

 5



3.  Define a Project Name, e.g., PnnSAM09 where nn is your team

number.
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Click Next.

          

On the Select an Import Source window you can:  (a) Use a Local file

system if you have previously downloaded the source PSB and DBD files

to your workstation, (b) Select a z/OS system and connect directly to

where your DBDs/PSBs are stored, or (c) If your IMS is at Version 12 with

the Catalog function enabled, you can obtain the Metadata directly from

the IMS Catalog.  For this lab (Part 1) we will use a connection to the

z/OS system and download source from z/OS to create the Metadata.

4.  Select z/OS system to obtain the source.  
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        Click NEXT.

                              

        Select the Add PSB button.

         You will be asked to provide the z/OS connection information.  

          

5.  On the Connect to z/OS System and Select Resources to Import

screen, click on the No z/OS connection to open the Connections box. 
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       Select New.   

                          

    

    In the Name field enter PnnSAM09 where nn is your team number

    In the Host name field enter zserveros.demos.ibm.com

    Keep the Port Number as 21 (FTP port) and Transfer mode as

Passive.
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    Click Apply and then OK. 

                       

    You will return to the Connect to z/OS System and Select Resources

to Import 

     box which now has your connection name.    

     To establish a connection, click the orange box (choose the

connection you created) to open the System z –FTP New Credentials

box.
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          In the userid field enter IMPOTxx where xx is your team number. 

          In the password field enter value provided by lab instructor.

          Click OK to establish the connection.

6.  You are now ready to retrieve your IMS resources. 

     Change the High-Level qualifier field to IMS.V12R1.SDFSISRC and hit

Enter on your  
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      PC keyboard.   

           

    Scroll down the list and select your PNNSAM09 PSB 

     Click Finish to activate the parsing of the PSB and DBD.
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Note you will be prompted to add the DBD DI21PART. Select the ADD

DBD button and then scroll and then select DI21PART Click FINISH.
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After parsing completes, your project is created. 

                 

Click on Finish.

Now it is time to add the fields to the segments that were not defined in

the DBD but are available in a Cobol Copybook.
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7.  In the Project Explorer box, click the + to open your PnnSAM09

project and navigate to the DBD folder. 

 

            To open the basic view double click on DI21PART.
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          You will see a graphical representation of the database. 

  The Manage Fields function is used to add more fields to the segment

since only the key fields are defined.  Right click on PARTROOT and

select Import COBOL or PL/I Structures. 

The Import Data Structures box opens. You will need to import the COBOL

structures.  The copybook was previously downloaded to your workstation.

Select the Browse button and look for the following directory

C:\share\anaheim2014\lab\source. 

Select C00SAM09 and click Open.                                  
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      Use the Drop down list to specify the structure for the PARTROOT

segment. 
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      Select Add to Import List button.
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Click Finish to complete the import process.

    The PARTROOT segment (table) will now have all the fields (columns).
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    Repeat the above process for the other segments. 

               

This completes the field definitions.
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Use Ctrl-S to save the changes or just use the x tab to close the view.

In the Project Explorer box, Follow the path IMS Universal Drivers Metadata >

Pnnsam09  and double-click PnnSAM09DatabaseView.java to view the updates

to the metadata.  

      This completes the building of the metadata.  

8.  You are now ready to use the Data Store Explorer (DSE) to access the IMS

PART database using the metadata you just created.

To connect to an IMS database use the New Connection wizard to create a

connection profile, so that you can connect to an IMS database and browse

existing data objects.
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If you already have the Data Source Explorer box open at the bottom of your

IMS Explorer window then you can skip the following instructions.

          If you do not have the Data Source Explorer box then click on the

Window tab at 

          the top of the IMS Explorer tool and follow the path:  Show View >

Other.  In the Show View > Other box, click + Data Management, select

Data Source Explorer and click OK.
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In the Data Source Explorer, right-click the Database Connections folder,

and click New. 
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The New Connections box opens up.  Select IMS as the database manager and

the driver name IMS Universal JDBC Driver as the JDBC driver.  
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Under Properties General tab 

     In the Connection Name field enter IMPOTxx where xx is your team number

     In the HOST field enter zserveros.demos.ibm.com

     In the Port number field enter 7013

     In the userid field enter IMPOTxx where xx is your team number

     In the password field enter value provided by lab instructor

     In the Metadata source drop down list select Local IMS Explorer project

     From the Project drop down list, select your project, e.g., PnnSAM09
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Under Properties select Optional tab
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In the Data store: field enter leave blank 

 Click Finish. 

The connection is displayed in the Data Source Explorer. 
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      The preceding picture shows that the connection is active.  If you need to

disconnect or re

      Connect, all you have to do is right click on the connection name and choose

your action.
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         To test the connection in the Data Source Explorer section under

Database

         Connections, right click on the connection name you defined, e.g.,

IMPOTxx.

 

        Expand the path until you can select PARTROOT.  Right click and select

Data then 

         click on Return All Rows to return data.

                        

     The results will be available in the box on the right under SQL Results.
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You can now also issue additional queries.  In between queries, you might need

to disconnect/reconnect the connections. Try looking at other tables/columns.

9. You can also try creating SQL calls using the SQL Query Builder.  

In the Project Explorer box, select your project e.g., PnnSAM09. 

Right click  New > Other  
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In the Select a Wizard box expand the Data folder and select SQL or

XQuery Script then click Next.

                   

You will see the New SQL or Xquery Script box change Name to

SelectScript1. Choose your Project PnnSAM09  from the dropdown

list.  Under the radio button SQL Query Builder note that you can

choose your Statement type. The default is Select.        
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When you have changed the values, click Finish.

You will need to select a connection profile for the database you want to

access. Choose the one you created earlier, e.g., IMPOTxx. Click Finish.

                    

The SQL Query Builder Box opens upl

In the Add a table window right click and select Add Table. 
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Use the drop down list to specify segments (tables)

 3



You will be able to choose which tables to add, and check which columns to

include.

          

Note how the script is built.

When you are done, position your cursor to the upper box, right click on the

Select statement that was built and choose the Run SQL option.
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The results can be viewed in the bottom box.

                     

Note that there are two tabs.  One for Status and one for Results.
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Save the SelectScript1.sql script you created by issuing Ctrl-s .
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You can also review the DL/I calls that were generated to support the SQL

request. Keeping the SelectScript1.sql window open, go to the top of the IMS

Explorer window, click on IMS Explorer and then on Show SQL to DLI call

translation tabs.

The SQL to DL/I Call translation window opens up.  Fill in the Connection profile with the

PnnSAM09 value you have been using and a PSB value of DFSSAM09. Cut and paste the

SQL statement from the SelectScript1.sql window and hit the Translate tab.
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Take the time now to continue using the same wizard to INSERT a new

PARTROOT e.g., Use 02PnnSAM09 (where nn is your team number) for the

partkey value.

                             

                                 

 

Run the SQL statement when you are done. Check the SQL Results at the
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bottom tab to make sure it ran to successful completion.

You can also try an UPDATE.  

                                    

Note for an UPDATE you will need to use the Set and Where tabs in the box

that allows you to choose your tables.  For example you can specify a

different value for the REJECT_CODE and qualify the call using the partkey

PART_NO_EDIT = 02PnnSAM09.  
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Check the SQL Results tab at the bottom of the window.

Finally, try the DELETE and remove the 02PnnSAM09 part that you

previously created.
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Accessing IMS data using SQL (with IMS catalog enabled)

Create a JDBC connection. 

In the Data Source Explorer, right-click Database Connections folder, and

click New. 

Select IMS as the database manager and the IMS Universal JDBC driver as

the JDBC driver. 

In the Connection Name field enter IMPOTxx where xx is your team

number     

     In the HOST field enter zserveros.demos.ibm.com

     In the Port number field enter 7001

     In the userid field enter IMPOTxx where xx is your team number

     In the password field enter value provided by lab instructor

Select IMS catalog as your Metadata source in the connection wizard.

Specify DFSIVP37 as the PSB name. 
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Click Finish.

To test the connection and return data

right click on the Connection and click Connect 

open folders until you get to Phonebook  right click select Data then Sample

Contents   
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this completes Accessing IMS data using SQL (with IMS catalog enabled)

Creating and running a unit test case for application debugging

You can create unit test cases and provide input message data in human

readable format for debugging. After you create a unit test case, you can

create variations of it with different input message data, to easily exercise

different code paths in the IMS transaction.

Create a transaction test project by
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 clicking File > New > IMS Explorer Transaction Test Project.

in the Project name field enter ivtno unit test

in Trancode field enter IVTNO

in Transaction name field enter ivp ivtno telephone

click Finish

After you create the Test Project you can use Import Data Structures to

define the Transaction Input and Output message structures. 
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Use the browse tab to find DFSIVTNO.cpy local file in

C:\share\anaheim\lab\source folder:

In the Data structure name: drop down list select INPUT_MSG

 and in Message name: drop list select IVTNO-INPUT**IN**
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and then select the Add to Import List tab

to import the output message structure change the Data structure name:

drop down list to OUTPUT_Area, Message name drop list to IVTNO-

OUTPUT**OUT** and select Add to Import List tab
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the following is the completed list

select the Finish tab to complete the definition. 
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The next step is to create a test case. 

Select your project and right mouse click then select New>IMS Transaction

Test Case  

in the test case panel verify your Project name is ivtno unit test and in the
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Test case name field enter ivtnodisplaycommand

 and select Finish

this opens the  Test Case Message Field Layout editor panel. 

Select Rename this Input and Output pair

and use the Remove button to delete this pair

Select the Add  tab to build IVTNO tran message pair. 

This opens the Add Test Case Input and Output Message pair panel. 
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In the Message pair name field enter ivtnocommand

In the IMS Destination Name field use enter IMSD the IMS Data Store value 

In the RACF user id field enter IMPOTxx where xx is your team number.
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Clear RACF group name: and RACF application name: fields   click Finish

The Test Case Message layout editor is used to specify the message pair to

be used. Select ivtnocommand and then select import message

in the import input and output messages panel verify message pair name is

ivtnocommand

in transaction name drop down list use ivp ivtno telephone

in input message drop down list use IVTNO-INPUT

in output message drop down list use IVTNO-OUTPUT

select Finish
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Define a new IMS transaction server connection by clicking New > Server. 

Select Next
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In the New Server wizard, click IBM > IMS Transaction Server.

In Server's host name field enter zserveros.demos.ibm.com 

select next
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in Server port field enter 7000

select Finish

From the test project, right-click and click Run As > IMS Explorer Application
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in the Edit configuration and launch panel

verify Name is ivtno unit test

in the Server name drop down list select the server you just created

Server port 7000

Client ID IMPOTxx
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select Apply and then select Run
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The Run an IMS transaction test case panel opens 

double click IN_TRANCDE Field value to edit the field
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enter IVTNO and select ok

double click on IN_COMMAND field and enter DISPLAY click ok

double click on IN_LAST_NAME field enter LAST1 click ok
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This completes building the input message
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select Close tab and save the changes
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in ivtno unit test > Test cases right mouse click  ivtnodisplaycommand.ttc

and select Run

the Run configuration panel 

verify the server configuration 

select Run tab to  
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in the middle of the panel select green button 

 

in the RACF properties panel enter your user id and password click ok

you may get the following message
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select Yes

This completes the lab.
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