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This hands-on lab provides the opportunity to access IMS databases from a 

distributed runtime environment provided by IBM’s IMS Enterprise Suite Explorer 

for Development.  This lab focuses on the use of the IMS Catalog and IMS 12. 

 

The IMS Enterprise Suite Explorer for Development 

 

The IMS Enterprise Suite Explorer for Development is an Eclipse-

based integrated development environment (IDE) for IMS 

application developers and database architects  

• It can also be integrated with other IBM Eclipsed 

based tools (RAD, RDz, Optim Data Studio)  

•  Provides end-to-end application development cycle  

 

 Graphical editors are used for development and visualization of 

• Program Specification Blocks (PSBs)   

•  Database Descriptions (DBDs) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 IMS Universal JDBC driver type-4 connectivity provides: 

• Relational view of IMS data 

• Graphical assistance to build SQL statements 

Generate 

See 
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Edit PSB 
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New support which incorporates the DLIModel Utility and the IMS 

12 Catalog functionality: 

• Provides current existing functionalities from IMS 

DLIModel Utility 

• Provides migration support of existing DLIModel 

Utility projects 

• Provides Metadata source for update to IMS Catalog 

• Provides Metadata access from the IMS Catalog  

 

 Distribution of the IMS Explorer is through a download capability  

• IMS Enterprise Suite V2.2.0.1 at 

http://www.ibm.com/ims 

 

 

IMS Connect and Open Database Manager   

 

• Open Database Manager (ODBM) is a Common Service Layer component 

• Receives database connection requests from IMS Connect 

• Translates incoming database requests from the DDM protocol into 

DLI calls expected by IMS 

• Translates responses to the client into the DDM protocol  

• Manages connections to IMS DB  

• Implements the DRA interface  
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IMS Enterprise Suite Explorer for Development 

In this part of the lab, the IMS Explorer is used to create the IMS Java 

Database View metadata by parsing the IMS PART Database PSB and 

DBD sources.  

 

1. Start IMS Explorer 

Click on Start > All Programs > IMS Enterprise Suite for Development > 

IMS Enterprise Suite for Development  

                                

You may be prompted to select a workspace.  A workspace is a directory that 

stores all of the files for the projects.  You can select your own directory, e.g., 

C:\share\explorerlab\workspace or any name you choose.      

 

                            

 

When Explorer startup is complete, you may be shown the Welcome 

Screen.  If so, close the Welcome page (x the tab at the top of the screen 

on the left). 
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2.  Click on File > New > IMS Explorer Project.   (If you don’t see “IMS 

Explorer Project” as a choice then click on File > New > Other and open 

the IMS folder and select IMS Explorer Project)        
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3.  Define a Project Name, e.g., PnnSAM09 where nn is your team 

number. 
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Click Next. 

           

On the Select an Import Source window you can:  (a) Use a Local file 

system if you have previously downloaded the source PSB and DBD files 

to your workstation, (b) Select a z/OS system and connect directly to 

where your DBDs/PSBs are stored, or (c) If your IMS is at Version 12 with 

the Catalog function enabled, you can obtain the Metadata directly from 

the IMS Catalog.  For this lab (Part 1) we will use a connection to the 

z/OS system and download source from z/OS to create the Metadata. 

 

4.  Select z/OS system to obtain the source.   
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        Click NEXT. 

 

                               

 

        Select the Add PSB button. 

         You will be asked to provide the z/OS connection information.   

           

5.  On the Connect to z/OS System and Select Resources to Import 

screen, click on the No z/OS connection to open the Connections box.  
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       Select New.    

                           

 

     

 

    In the Name field enter PnnSAM09 where nn is your team number 

    In the Host name field enter zserveros.demos.ibm.com 

    Keep the Port Number as 21 (FTP port) and Transfer mode as 

Passive. 
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    Click Apply and then OK.  

 

                        

    You will return to the Connect to z/OS System and Select Resources 

to Import  

     box which now has your connection name.     

               

 

     To establish a connection, click the orange box (choose the 

connection you created) to open the System z –FTP New Credentials 

box. 
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          In the userid field enter IMPOTxx where xx is your team number.  

          In the password field enter value provided by lab instructor. 

          Click OK to establish the connection. 

 

6.  You are now ready to retrieve your IMS resources.  

           

 

     Change the High-Level qualifier field to IMS.V12R1.SDFSISRC and hit 

Enter on your   
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      PC keyboard.    

            
 

    Scroll down the list and select your PNNSAM09 PSB  

             

 
 

     Click Finish to activate the parsing of the PSB and DBD. 
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Note you will be prompted to add the DBD DI21PART. Select the ADD 

DBD button and then scroll and then select DI21PART Click FINISH. 
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After parsing completes, your project is created.  

 

                  

 

Click on Finish. 

 

Now it is time to add the fields to the segments that were not defined in 

the DBD but are available in a Cobol Copybook. 
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7.  In the Project Explorer box, click the + to open your PnnSAM09 

project and navigate to the DBD folder.  

                         

  

            To open the basic view double click on DI21PART. 
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          You will see a graphical representation of the database.  

 

  The Manage Fields function is used to add more fields to the segment 

since only the key fields are defined.  Right click on PARTROOT and 

select Import COBOL or PL/I Structures.  

                  

 

 

The Import Data Structures box opens. You will need to import the COBOL 

structures.  The copybook was previously downloaded to your workstation.   

Select the Browse button and look for the following directory  

C:\share\boston2013\lab\source.  

 

Select C00SAM09 and click Open.                                   
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      Use the Drop down list to specify the structure for the PARTROOT 

segment.  
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      Select Add to Import List button. 
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Click Finish to complete the import process. 

    The PARTROOT segment (table) will now have all the fields (columns). 
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    Repeat the above process for the other segments.  

                

This completes the field definitions. 
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Use Ctrl-S to save the changes or just use the x tab to close the view. 

 

In the Project Explorer box, Follow the path IMS Universal Drivers Metadata > 

Pnnsam09  and double-click PnnSAM09DatabaseView.java to view the updates 

to the metadata.   

 

             

 

 

      This completes the building of the metadata.   

 

 

 

8.  You are now ready to use the Data Store Explorer (DSE) to access the IMS 

PART database using the metadata you just created. 

To connect to an IMS database use the New Connection wizard to create a 

connection profile, so that you can connect to an IMS database and browse 

existing data objects. 
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If you already have the Data Source Explorer box open at the bottom of your 

IMS Explorer window then you can skip the following instructions. 

          If you do not have the Data Source Explorer box then click on the 

Window tab at  

          the top of the IMS Explorer tool and follow the path:  Show View >  

Other.  In the Show View > Other box, click + Data Management, select 

Data Source Explorer and click OK. 
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In the Data Source Explorer, right-click the Database Connections folder, 

and click New.  
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The New Connections box opens up.  Select IMS as the database manager and 

the driver name IMS Universal JDBC Driver as the JDBC driver.   
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Under Properties General tab  

     In the Connection Name field enter IMPOTxx where xx is your team number      

     In the HOST field enter zserveros.demos.ibm.com 

     In the Port number field enter 7001 

     In the userid field enter IMPOTxx where xx is your team number 

     In the password field enter value provided by lab instructor 

     In the Metadata source drop down list select Local IMS Explorer project 

     From the Project drop down list, select your project, e.g., PnnSAM09 
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Under Properties select Optional tab 
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In the Data store: field enter IMSD 

 

 Click Finish.  

 

 

The connection is displayed in the Data Source Explorer.  
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      The preceding picture shows that the connection is active.  If you need to 

disconnect or re 

      Connect, all you have to do is right click on the connection name and choose 

your action. 
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         To test the connection in the Data Source Explorer section under 

Database 

         Connections, right click on the connection name you defined, e.g.,  

IMPOTxx. 

  

        Expand the path until you can select PARTROOT.  Right click and select 

Data then  

         click on Return All Rows to return data. 

                         

     The results will be available in the box on the right under SQL Results. 
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You can now also issue additional queries.  In between queries, you might need 

to disconnect/reconnect the connections. Try looking at other tables/columns. 

 

 

9. You can also try creating SQL calls using the SQL Query Builder.   

 

In the Project Explorer box, select your project e.g., PnnSAM09.  

Right click  New > Other   
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In the Select a Wizard box expand the Data folder and select SQL or 

XQuery Script then click Next. 

                    

 

You will see the New SQL or Xquery Script box change Name to 

SelectScript1. Choose your Project PnnSAM09  from the dropdown 

list.  Under the radio button SQL Query Builder note that you can 

choose your Statement type. The default is Select.         
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When you have changed the values, click Finish. 

 

You will need to select a connection profile for the database you want to 

access. Choose the one you created earlier, e.g., IMPOTxx. Click Finish. 

                     

The SQL Query Builder Box opens upl 

In the Add a table window right click and select Add Table.  
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Use the drop down list to specify segments (tables) 
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You will be able to choose which tables to add, and check which columns to 

include. 

           

Note how the script is built. 

 

When you are done, position your cursor to the upper box, right click on the 

Select statement that was built and choose the Run SQL option. 
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The results can be viewed in the bottom box. 

                      
 

Note that there are two tabs.  One for Status and one for Results. 
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Save the SelectScript1.sql script you created by issuing Ctrl-s . 
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You can also review the DL/I calls that were generated to support the SQL 

request. Keeping the SelectScript1.sql window open, go to the top of the IMS 

Explorer window, click on IMS Explorer and then on Show SQL to DLI call 

translation tabs. 

 

 

The SQL to DL/I Call translation window opens up.  Fill in the Connection profile with the 

PnnSAM09 value you have been using and a PSB value of DFSSAM09. Cut and paste the 

SQL statement from the SelectScript1.sql window and hit the Translate tab.     
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Take the time now to continue using the same wizard to INSERT a new 

PARTROOT e.g., Use 02PnnSAM09 (where nn is your team number) for the 

partkey value. 

 

                              

 

                                  

  

Run the SQL statement when you are done. Check the SQL Results at the 
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bottom tab to make sure it ran to successful completion. 

 

You can also try an UPDATE.   

                                     

 

Note for an UPDATE you will need to use the Set and Where tabs in the box 

that allows you to choose your tables.  For example you can specify a 

different value for the REJECT_CODE and qualify the call using the partkey 

PART_NO_EDIT = 02PnnSAM09.   
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Check the SQL Results tab at the bottom of the window. 

                             

 

 

 

Finally, try the DELETE and remove the 02PnnSAM09 part that you 

previously created. 
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This completes the lab. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


