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What is it and Why do I Care? 
• IBM’s “New Face of CICS” 

• Eclipse Based graphical tooling interface for CICS  

• Connects to CICS via the CICSPlex Web User Interface (WUI) System Task 

• Utilizes the existing CICSPlex (CPSMOBJ) Security rules 

• Capabilities 
• User friendly 

• Easy to find what you are looking for 

• Ability to dynamically/easily/quickly manipulate your screen, so that you are only a few clicks away 
from the information, you REALLY need 

• Expandable, via Plug-ins 
• For Shops that have CICS Tools, Explorer provides an integrated view  

• Even for Shops without CICS Tools, Explorer provides an integrated view of their CICS Environment  

• Currently CICS Explorer can be used to perform many, but not ALL Administration 
Functions 

• IBM Direction 
• IBM has made a significant commitment to Explorer 

• New releases GA approximately every 90 days 

• IBM has set up a CICS Explorer Forum, for users to comment , ask questions, etc. 

• From a Changing workforce perspective, IBM feels that Explorer will help shorten the learning curve 
for new IT Professionals 

• Features like CICS Event Processing, CICS Application Bundling, etc. REQUIRE CICS Explorer  

IBM has “No plans to make CICS Explorer a chargeable product” 
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Workspace Logistics  
• What is the CICS Explorer Workspace? 

• As with a traditional Eclipse workbench, CICS Explorer stores all user specific 

information in the users CICS Explorer Workspace. 

 

 

 

 
 

• Default Location: "C:\Documents And Settings\username\.cicsexplorer” 

• Do I Care What’s in the Individual User’s CICS Explorer Workspace? 

• When considering Deployment Options, you MUST consider if it’s necessary to 

preserve  the contents of Individual User Workspaces, and plan accordingly 

 

 
 

  

- User Credentials  - Connections (Depends on Deployment)  

- Last User display   - CICS Event  Processing Projects 

- Installation Perspectives   - CICS Application Bundle Projects 

- Java OSGI Bundles (SDK)  - Etc.  
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Installation and Configuration  

  • Download the Appropriate CICS Explorer Base and Plug-in(s)  

• www.ibm.com/software/htp/cics/explorer/ 

• Starting CICS Explorer for the First Time  

• The workbench starts and the Welcome View is displayed 

 

 

 

 
 

 
 

  

Overview 

Get an overview of the features 

Tutorials 

Go through tutorials 

First Steps 

Take you first 

steps 

Workbench 

Go to the workbench 

You can re-open the  

Welcome View at any  

time by Selecting  
 

Help > Welcome  
 

From the workbench  

menu bar.  

Note: A CICS  

Explorer Workspace  

is Created the first  

time you launch  

Explorer   

Note: Since Explorer is Eclipse based anyone could build a Plug-in for it  

http://www.ibm.com/software/htp/cics/explorer/
http://www.ibm.com/software/htp/cics/explorer/
http://www.ibm.com/software/htp/cics/explorer/
http://www.ibm.com/software/htp/cics/explorer/
http://www.ibm.com/software/htp/cics/explorer/
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Installation and Configuration  

  • Connections and Credential Administration (CICS Explorer  v1.1.1 + ) 

• The README file details the steps 

• Credentials contain user information that will be used by Connections     

 

 

 

 
 

 
 

  

If your Passwords change 

periodically, you may want to 

leave the “Save password” box 

unchecked.  

CMCI Connection Example 

- Name: Change to     

  anything you want 
 

- Host  name: TCP/IP host   

  name of your CICSPlex SM  

  WUI server or your stand- 

  alone CICS region  
 

- Port number: CMCI port    

  Number you configured  
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Installation and Configuration  

  • Connection Sharing (CICS Explorer  v1.1.1 + ) 

 

 

 

 
 

 
 

  • You can choose to Export your Connections to a .pref  

  file and Share the file among your Users 

• Users Could Access the .pref file via: 

- E-mail  

- Shared Network Drive 

- Shared Network Server 

- Mainframe Unix (zFS), using CICS to  

  Access (TCPIPSERVICE and URIMAP) 

- Etc.   
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Installation and Configuration  

  • Connection Sharing (Using zFS Example) 

• Use CICS Explorer to Export your current Connections to a .pref file 

• Upload the .pref file to zFS (XMIT ASCII) 

• Permissions for the zFS (.pref) file must allow the CICS Region Userid READ Access  

 Example zFS Location: /explorerconn/ 

 Example File Name: CICS_Explorer_Connections.pref  

• Create a CICS TCPIPSERVICE definition, using an Open Port and your defaults  

 Example TCPIPSERVICE Name: LMFCONN 

 Example TCPIPPORT: 8888 

• Create a CICS URIMAP with the following Attributes Specified 

 Example URIMAP Values: 

 HOST              : * 

 PAth                : /ciceconn/*    (Any Name you choose. Used in the URL) 

 Tcpipservice : LMFCONN     (See Example TCPIPSERVICE Name Above) 

 Mediatype      : text/xml 

 HFsfile            : /explorerconn/CICS_Explorer_Connections.pref  (See Above) 

• Install the TCPIPSERVICE and URIMAP in Your CICS Region 
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Installation and Configuration  

Host Address TCPIPSERVICE 

Port 
URIMAP Path  zFS .pref File Name 

<?xml version="1.0" encoding="UTF-8" ?>  
- <connections providerID="1234567892894-1"> 

 - <type type="com.ibm.cics.sm.comm.sm.connection"> 

      <configID CONFIG_NAME="SHARE Connection A" CREDENTIAL_ID="1234567896008-0“   

         PORT_NAME="7777" SERVER_NAME="myhostA.share.com" configID=" SHARE Connection A  "     
         host="myhostA.share.com" name=" SHARE Connection A " port="7777" />  
      <configID CONFIG_NAME="SHARE Connection B" CREDENTIAL_ID="1234567896008-0“   
        PORT_NAME="7777" SERVER_NAME="myhostB.share.com" configID=" SHARE Connection B  "   
        host="myhostB.share.com" name=" SHARE Connection B " port="7777" />  
      <configID CONFIG_NAME="SHARE Connection C" CREDENTIAL_ID="1234567896008-0“     
        PORT_NAME="7777" SERVER_NAME="myhostC.share.com" configID=" SHARE Connection C  "   
        host="myhostC.share.com" name=" SHARE Connection C " port="7777" />  
    </type> 
  </connections> 

• Connection Sharing (Using zFS Example - Continued) 

• Based on the Example Attributes, you can now open a web browser and type the 

following URL address to Test the Setup: 

  http://myhostA.share.com:8888/ciceconn/CICS_Explorer_Connections.pref 

 

  
 

• The following is an example of what should be Returned in the Web Browser 

 
 

  

http://prod1x01.bankofamerica.com:1712/ciceconn/CICS_Explorer_Master_Connections.pref
http://prod1x01.bankofamerica.com:1712/ciceconn/CICS_Explorer_Master_Connections.pref
http://prod1x01.bankofamerica.com:1712/ciceconn/CICS_Explorer_Master_Connections.pref
http://myhosta.share.com:8888/ciceconn/CICS_Explorer_Connections.pref
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Installation and Configuration  

  • Connection Sharing (Using zFS Example – Continued) 

 Any user can Load or Import  

Connections from the zFS file 

using the same URL you entered 

into the Web Browser.   

 Upon first Connection the User 

will be asked what Credential they 

want to Associate with that 

Specific Connection Definition.    
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Deployment Considerations  
• Intended Users 

• Number of users  

• Current WUI Users  

• User Type  (Admin, Read, Mixed) 

• Will certain groups use Plug-ins? 

• User Support 

• Upgrade Administration 

• Frequency (GA Every 90 Days) 

• Upgrade method 

• Full Replacement 

• Automatic Update 

• Archive Site File  

• Plug-in Upgrades 

 

 

 

• Installation Specific Audit 

Requirements 

• Change Control 

• Processes and Procedures 

• Service Level Agreements 

• Workspace Administration 

• Is it important to preserve today? 

• Will it be important to preserve? 

• CICS Event Processing, Application 

Bundling, etc. Project Administration 

• Backup 

• Recovery 

• Connection Administration 
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Deployment Considerations  
• Option One - Local on Each User Workstation 

• Each user has an individual copy installed on their workstation 

• Very little Administrative Control 

• Option Two - Shared Network Drive 

• Installed/Accessed from a Shared Network Drive 

• Depending on Network Configuration may have response time issues      

• Option Three - Citrix Server 

• Installed on a Network (Citrix) Server 

• Full Administrative Control 

• Allows you to leverage Citrix Scripting 

Other Resources 

For any Deployment option where the .exe file is shared you should review the Eclipse 

guidelines for multi-user installations  
 

http://help.eclipse.org/indigo/index.jsp?topic=/org.eclipse.platform.doc.isv/reference/misc/multi

%255Fuser%255Finstalls.html 

http://help.eclipse.org/indigo/index.jsp?topic=/org.eclipse.platform.doc.isv/reference/misc/multi_user_installs.html
http://help.eclipse.org/indigo/index.jsp?topic=/org.eclipse.platform.doc.isv/reference/misc/multi_user_installs.html
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Deployment Considerations  

  • Option Four – JWS (Java Web Start) 

• An IBM developerworks article, “Deploy CICS Explorer using Java Web Start” was 

published, on April 19, 2012    

• IBM officially announced JWS at the IBM IMPACT 2012 conference, in 

conjunction with an IBM United States Software Announcement (ALET 212-119), 

dated April 24, 2012 

• JWS is an industry standard solution for deployment of Java applications from the 

web, not a component of CICS Explorer.  

• A CICS Explorer Installation Administrator would: 

 Download a version of CICS Explorer  

 Customize it to the Installation standards.  

 Package the customized version as a JWS JNLP (Java Network Launching Protocol) file.  

 The JNLP file is then stored in an accessible installation location.  

 The first time a user points their browser to the JNLP file, a copy of CICS Explorer is loaded into 

the user’s browser cache.  

 If a new JNLP file is deployed, the Installation user’s copy is updated at the next execution.  
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CICS Explorer Navigation (Live Demo)  

• Accessing Help and What’s New 

The frequency of 

New CICS Explorer 

Releases makes 

the Internal Help 

function a great 

(UTD) information 

source. 

 

Each New Release 

includes a “What’s 

New” section, 

detailing new 

functionality   
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CICS Explorer Navigation (Live Demo)  

• Screen Layout 

Explorer View - Only View  that can’t be moved 

Explorer 
Control the 

Scope of 

Resources 

Being Viewed 

Event Tab 
View System 

Events 

Repo View  
CICSGRP(s) 

and  

CICSSYS(s) 

Def’s. Can 

also be used 

to Control 

Scope  

Perspective Selection Individual Resource Tabs 
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CICS Explorer Navigation (Live Demo)  

• Zoom In/Out of a View 

• Double Click the View Tab to Zoom in or Back out of a view 

 



17 

CICS Explorer Navigation (Live Demo)  

• Resizing a View  

• Float the Cursor over the inside edge of the view until it changes to a 

Double-Ended (vertical or horizontal) arrow.  
 

 

• Drag the edge to the desired size 

 
• Moving a View 

• Position the Cursor on the 

Tab of the View you want to 

move 

• Drag it to the area of the 

screen you want to position 

it in. 

• Your cursor will change to 

one of the following, 

indicating where the screen 

will be positioned. 

Cursor Where the View will be moved 

Position above the Current View (the View that 

is underneath the cursor)  

Position Below the Current View  

Position to the Right of the Current View 

Position to the Left of the Current View 

Stack: The View is stacked as a Tab in the 

Current View 

Restricted: Can’t be positioned in Current Area 

Open a New Window. Drag outside the 

workbench to position in a new window. Note: 

Click on the New Window and Drag Back to 

position it back  
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CICS Explorer Navigation (Live Demo)  

• Move Column - Click on Column and Drag to the Desired Location 

• From the View Menu you can:  

 

 

 

• Customize  

Columns 

• Refresh the View 

• Reset Columns 

• Equalize Column    

 Widths 

• Choose filter    

  attributes 
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CICS Explorer Navigation (Live Demo)  

• Sort Column  

 

 

 Column Sort 

Indicator 

 

As you click on 

the Column the 

sort order 

rotates as 

follows:   
• Sort ascending  

• Sort descending  

• Default sort order 

Note: This function ONLY works if you are 

connected to a CICS TS v4.2 + WUI (via 

CMCI) and running CICS Explorer v1.1.0 +  
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CICS Explorer Navigation (Live Demo)  

Filter of EYU* Used Right click on an individual entry to take Action on it. Refresh View 

Actions Available  

Perform actions on Multiple Entries, that are grouped together by 

doing Click, Shift, Click (to Select), and then Right Click 

Perform actions on Entries not grouped together by doing Click, 

CTRL, Click, CTRL (to Select ), and then Right Click  
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CICS Explorer Navigation (Live Demo)  

• z/OS Perspective - FTP Connection (View z/OS Data)  

 

 

 Data Sets View:  

Jobs View:  

Unix Files View:  

View and/or Manipulate File Contents 

 File Statistics 

Note: The FTP.DATA Server configuration  file must specify JESINTERFACELEVEL 2       
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What’s New in CICS Explorer v5.1? 
• Workspace Preferences and History 

• Select Preferences from the Window Menu  

• Expand Eclipse Platform and Select Workspaces 

• You can choose to be prompted for a 

workspace location at startup 
  

• You can choose the number of recent 

workspaces in the history, however you 

can not set it to less than 5  
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What’s New in CICS Explorer v5.1? 
• Switch Workspace Option 

• Select Switch Workspace from the File Menu, and Click Other  

• From the Workspace Launcher 

you can: 

• Change  to/Create a New 

workspace  

• Switch to a previous 

workspace in your history 

• Choose to copy settings 

• Note: once you Click OK, CICS 

Explorer will Close and Reopen  
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What’s New in CICS Explorer v5.1? 
• Support for z/OSMF 

• In v5.1 you have the ability to connect to the z/OSMF product.  

• Using z/OSMF you can view the output of active jobs, and cancel or delete jobs. 

• See “Using the IBM z/OS Management facility” for more information. 

• Column Customization (Behavior Change) 

• If you are connected to an LPAR and Customize the Columns in a view: 

• During the same CICS Explorer session, if you Connect to another LPAR the Column 

Customization will remain the same.  

• At the start of a New CICS Explorer Session, the View will show the Default  (without your 

Column Customization). As soon as you Connect to an LPAR your Column 

Customization will be there 
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What’s New in CICS Explorer v5.1? 
• New Functions 

• Ability to copy and paste resource data to a spreadsheet 

• Ability to Perform a System Dump  

• Ability to create a new resource from an existing definition  

• Ability to create a z/OS UNIX file  

• Ability to export a file or folder to a z/OS UNIX file system  

• Ability to create a new data set  

• Ability to rebuild the Secure Sockets Layer (SSL) for a CICS region  

• Connections use Secure Sockets Layer (SSL) 

• Perspective Changes 

• The new Cloud Perspective contains a core set of views to help you get started 

with cloud administration. 

• Accessible from the Window > Open perspective > Other Menu on the toolbar 
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What’s New in CICS Explorer v5.1? 
• Seven New Operations Views 

• Applications View   Operations Menu  

• Cloud Explorer View   Operations Menu 

• Data Tables View (CMDT)  Operations > Files Menu 

• EP Adapter Sets View   Operations > Event Processing Menu 

• Physical Datasets View (DSNAME) Operations > Files Menu  

• Platforms View    Operations Menu 

• z/OS Workload Management View Window > Show View > Other >  

      SM Administration Definitions 

• Two New Definition Views 

• Applications Definitions View Definitions Menu 

• Platforms Definitions View  Definitions Menu 

• Changes to Existing Views 

• Tasks View – New Field "MRO/LU6.2 session allocate wait time”  

• Completed Tasks View – New Field "IS Allocate Wait Time“ (IPIC Session Wait) 
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