Collaborative Development using IBM Rational Team Concert

Work Items, Software Configuration Management, and Team Collaboration Platform for COBOL, Java, PL/I, C/C++, and Assembler Development

Student Exercises

Liam Doherty (dohertl@au1.ibm.com)
Rosalind Radcliffe (rradclif@us.ibm.com)

Visit Jazz.net at:
http://jazz.net/
Fourth Edition (February 2012)

The information contained in this document has not been submitted to any formal IBM test and is distributed on an "as is" basis without any warranty either express or implied. The use of this information or the implementation of any of these techniques is a customer responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. While each item may have been reviewed by IBM for accuracy in a specific situation, there is no guarantee that the same or similar results will result elsewhere. Customers attempting to adapt these techniques to their own environments do so at their own risk.

Copyright International Business Machines Corporation 2009, 2012 All rights reserved.

This material may not be reproduced in whole or in part without the prior written permission of IBM.

Note to U.S. Government Users - Documentation related to restricted rights - Use, duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule Contract with IBM Corp.
## Table of Contents

### OVERVIEW
- Module 1 Using the Admin Console 4
  - 1.1. ADMIN CONSOLE 6

### Module 2 Setting up the Team
- 2.1. START THE RATIONAL TEAM CONCERT CLIENT 13
- 2.2. CREATE A REPOSITORY CONNECTION AND CONNECT TO A PROJECT 14
- 2.3. MEET THE TEAM AND ADD YOUR NEW USER 17
- 2.4. CHANGING USERS AND REPOSITORY CONNECTION 21

### Module 3 Planning Your Work
- 3.1. CREATING WORK ITEMS 24
- 3.2. CREATING AN ITERATION PLAN 32
- 3.3. POPULATING PLANS WITH WORK ITEMS 33

### Module 4 Work Item Queries
- 4.1. PREDEFINED QUERIES 37
- 4.2. CREATING QUERIES FROM SCRATCH 39

### Module 5 Web User Interface
- 5.1. WEB USER INTERFACE: WORK ITEMS, ITERATION PLANS, REPORTS, DASHBOARDS 43

### Module 6 Source Code Management (SCM)
- 6.1. SOURCE CODE MANAGEMENT WITH RTC 48
- 6.2. WORKING WITH LOCAL PROJECTS 57
- 6.3. OPTIONAL: ENABLING AUTOMATIC CHECK-INS 67

### Module 7 Enterprise Build (SCM)
- 7.1. Z/OS ANTZ BUILD 69

### Module 8 Source code management with the ISPF Client
- 8.1. LOGGING INTO THE SHARE LPAR 80
- 8.2. STARTING AND LOGGING INTO THE ISPF CLIENT 80
- 8.3. WORKING WITH YOUR REPOSITORY WORKSPACES 84
- 8.4. MAKING CHANGES TO PROGRAMS 87
- 8.5. PERFORMING BUILDS 95
- 8.6. DELIVERING YOUR CHANGES TO THE STREAM 100

### Module 9 Optional: Exploring Changes and Traceability
- 9.1. WHAT CHANGES WERE MADE FOR A WORK ITEM 103
- 9.2. WHO CHANGED THIS FILE, WHEN AND WHY? 106
Overview

This lab is for use with Rational Developer for z (RDz) integrated with Rational Team Concert (RTC). RDz is an integrated development environment (IDE) that consists of a workbench and a common set of tools to help you develop and maintain Assembler, COBOL, C/C++, and PL/I. RTC provides project tracking, planning, build, collaboration and source code management. RDz and RTC can be installed separately or together in an integrated environment where both RDz and RTC share the same eclipse client. The lab will demonstrate how to use RTC to track progress using Work Items and Iteration Plans. It will show how to manage source code with the Jazz Source Code repository. This lab is split into parts to allow you to work on the pieces you most want to learn about.

Depending on what your interest is in RTC you may want to look at different components. Chose the modules you wish to do based on your interests.

Basic RTC knowledge

If you are just after some basic knowledge of RTC, maybe you are a manager and want to see what RTC can do through the use of work items, then this is a good place to start.

1. Module 3. Planning your work
2. Module 4. Work Item queries
3. Module 5. Web user interface

RTC Planning and Administration

If you are likely to be setting up RTC, creating users or as a project leader, creating plans then these modules will be best suited for you.

1. Module 1. Using the Admin Console
2. Module 2. Setting up the team
3. Module 3. Planning your work

RTC Mainframe code development using Eclipse and RDz

If you are a developer but are more used to working in a graphical IDE, then these modules will show you some of the source code capabilities of RTC.

RTC Mainframe code development using the RTC ISPF Client

Still love the ISPF editor? Then have a look at how source code management through RTC is still achieved through an ISPF interface, so you can still use the editor you love.

1. Module 8. Source code management with the ISPF Client
2. Module 7. Enterprise Build (SCM) – To understand how build definitions are defined

If you get through a set of modules then take a look at a different one, or use this lab at your site and install RTC as a trail.
Module 1 Using the Admin Console

Lab Scenario
The admin console provides the ability to configure the server, project areas, and users. In this scenario you will learn about the different parts of the admin console, as well as create a new user for your use during the lab.

1.1. Admin Console

a) It may be necessary to start the Jazz team server. Check on your desktop for a command prompt window with a title of “Tomcat”. If there is one running then you do not need to do anything. If there isn’t one running then double click on the “Start Jazz Team Server” icon on your desktop. The wait until you see the “INFO: Server startup” message in the command prompt box.

b) The Web admin console is used to perform crucial administrative functions that you can’t perform elsewhere. Open Internet Explorer to https://sharexp1.9443/lts/admin (this is also bookmarked for you as “Home – Server Administration - Rational Jazz Team Server”) and login with user id rtcadmin and the password rtcadmin to access the admin console. Prior to getting the login screen you may get a certificate error screen. If you get this then click on the option to “Continue to this website (not recommended)”. The first screen you will receive is the Jazz Team Server Administration home, where you can choose between Server Administration and Application Administration.

c) Click on Jazz Team Server – Server Administration. On the administration screen shown next the main links or pages are located across the top. The submenu is on the left. The
Status Summary is an overview of general server statistics and is a good starting point for server troubleshooting. It should look like the screenshot below once you are logged in.

d) The next category under Status on the left-hand menu is “Statistics”. This provides averages and counts for web services and asynchronous tasks as well as cache size, hits, and misses.
e) The next category, Component Status shows which components are installed and active. If you see multiple red X’s here, functions will be broken. The category under Component Status, Active Services, is useful in an environment with more than 1 user using RTC since it displays those services currently running on the server and the duration.

f) Explore the Configuration categories of Registered Applications, Email Settings, Database Connection, Feed Settings, Themes and Advanced Properties. We will make one change in the Advanced Properties find the host name field and click edit, add the ip address of your local image to the hostname, so that it will be reachable from the z/OS machine when doing build. You will need to return to the top of the page and click Save to save your changes.

Note : To find the Host Name field press ctrl-F to bring up a find box, then enter Host Name in the box. This will quickly locate the Host Name field. To find your ip address, open a command prompt and type ipconfig. The ip address should be listed there.

g) Let’s now look at application administration. From RTC version 3.0 onwards the change and configuration component (ccm) now runs as an application that depends on the Jazz Team Server (jts). Other applications, such as Rational Quality Manager (qm) also run as applications under the Jazz team Server. Click on the Home link at the top of the page to take you back to the Jazz Team Server Administration Home. Click on the Change and Configuration Management (/ccm) – Application link and you will now be presented with the Status Summary page for the ccm application. Here you can see the version of both the ccm application and the Jazz foundation core libraries.
h) On the page links across the top, click the **Templates** link. This page is where you can deploy predefined process templates (this has already been done for you), import templates, or manage existing templates.
i) The next page we will explore is **User Management**. On the menu bar at the top of the screen click the **Users** option. Use this page to create, edit, or archive users. Archiving a user is the only way to not have a user show up in search results. You can’t delete users.

![User Management Page](image)

j) Create a user by clicking the **Create User** option at the top right of the screen. You will create the team user you will use for this lab. Please create the user substituting the number of your lab machine for the number in the user name. Create a user `labuser#` when you create a user this way, the password will be the same as the user id (`labuser#`) You can modify a users repository permissions and the client access licenses on this page. You must give users a **Rational Team Concert - Developer for IBM Enterprise Platforms** client access license to have write privileges which are needed to save work items, save queries, and check in code. You can also upload a picture which will be displayed with that user. For this lab, add your user name, user id, and email address and assign your user **Developer for IBM Enterprise Platforms** license, and all of the repository permissions.
k) The last page we will explore in the RTC admin console is **Project Area Administration**. Click on Project Areas on the menu bar at the top of the screen. As the name implies, this is the interface used to manage Project Areas. You can create new Project Areas, archive Project Areas, view the active Project Areas, and manage Project Areas. To manage a particular Project Area, click on the Project Area name as seen below. You can add administrative users to project areas, add members, and change the process template with this editor.

Let’s add the user id we just created to the project area as an administrator. Go to the administrator section and click **add**… then in the **Select Users** box click **Show All**. Then select your user id followed by the **Add and Close** button.

l) Click OK to return to the project Administration screen. You must now click **Save** to save your changes.

You may be asked if you want to send an invitation email to your new member, as email notification is disabled just hit the cancel button.
Conclusion

This concludes Module 1. You now should be familiar with the functions available from the admin console and have a user created to perform the lab.
Module 2  Setting up the Team

Lab Scenario
In this lab you will focus on how to connect to a repository and its defined project areas. You will also learn about teams, and add your new lab user to the team area for the lab.

2.1. Start the Rational Team Concert client

a) You should find the icon for Rational Team Concert on your desktop (IBM Rational Team Concert), double click to start the client. (The client has the Rational Developer for z client also installed for use during this lab).

You will be prompted with the Workspace Launcher where you can select your Eclipse workspace. This is a directory where all your settings are managed and where all your source code is stored. The workspace, RTClab, should be listed by default but if it is not just click the downward pointing arrow in the box and select C:\workspace\RTClab. Click OK. Use the RTClab workspace for this lab, as it is preconfigured for you.

Note: If you have already gone past the workspace launcher selection box, you can still get to the required workspace by switching workspaces. Go to File → Switch Workspace and then either choose the workspace name or choose Other and type the workspace name in the field, or use the downward pointing arrow, or Browse to the workspace.

b) You should now be in the Work Items Perspective, as shown in the picture below. If you are not, you can open the Perspective by selecting Window → Open Perspective → Work Items
2.2. **Create a repository connection and connect to a project**

a) A repository connection has already been created for you to your local server, however it is using the rtcadmin userid and we need to log in with the user id we just created in the previous exercise. Right click on the repository connection node that says `rtcadmin@sharexp1` and select **Properties** as shown below.
b) In the dialog box select the Jazz Repository Connection on the left side of the screen. Then change the user id and password to the one you created previously (labuser#). The password is the same as the user id. Alternatively if you did not create a userid just login with labuser99 (password labuser99) which has already been created for you. Press **OK**.

c) If you get any certificate problems when connecting, just accept the certificate permanently:
d) Next you need to connect to the project area. Right click on the repository connection you have just logged into and select **Manage Connected Project areas**...

![Manage Connected Project areas](image)


e) On the Connect to project areas screen select the RTC Lab Project and click Finish.
f) You will now see the project added to the tree, and if you expand it you will see a collection of new nodes that we will explore later:

2.3. Meet the team and add your new user

a) Open the Team Organization view. Right click on the RTC Lab Project, and select the Show in Team Organization.
b) Expand the **RTC Lab Project** team. Here you will see all the current team members for the **RTC Lab Project** team. You can modify a user's account from here by double-clicking the user's name and using the interface that opens.
c) The next step is to add yourself to the RTC Lab Project. Start by opening the project area definition by right clicking on the project in the Team Artifacts view and selecting **Open**.

You will need to select the Team Artifacts tab to get back to the correct view. This is the left most tab.

d) Here you will see the project area definition, including, in the **Members** area, the users assigned to the project area. Click on the **Add...** button to add your new user id, `labuser#`
Note: Double clicking on a tab, such as the RTC Lab Project Tab, will open the tab into full screen. Double clicking it again will put it back into its collapsed mode.

e) In the search windows search for users that start with “l” and press Search and you should find your new user. Click Select so that your new user is in the selected users list.

f) Click Next, Grant all permissions to your user labuser# by selecting all Available Roles and using the Add button to move to the Assigned Roles.
g) Click Finish and then make sure you click **Save** on the project area to save your changes.

2.4. Changing users and repository connection

a) Another way to change the user that is connected to the jazz repository is to go via the connection properties. From the **Team Artifacts** view (**Window → Show View → Team Artifacts**), right-click on the repository connection and click **Properties**
b) Here you can enter a new URI if connecting to a different repository.

**Note:** This is for instructional purposes only. This lab image is already configured to communicate with the appropriate repository. Leave the repository URI the same and change the user/password to `labuser#/labuser#`, where # is the number you used. Select Jazz Repository Connection on the left if it is not selected by default. Press Ok.
Now you are connected to the Jazz Team Server on your local machine denoted by the URI https://sharexp1:9443/ccm/. You are connected as user labuser#.

Conclusion

This concludes Module 2. You are now able to easily connect to an existing Jazz repository and project area as any valid user and begin collaborating with your teammates. You have also added your individual user to the team to begin work.
Module 3  Planning Your Work

Lab Scenario
You want to track all the work on your projects. All your work (tasks, defects, enhancements) is based around the concept of Work Items. You hear how Work Items are fundamental to Rational Team Concert and how you use these work items to track the work you do in each item. You prioritize your work so that you can do the right things at the right time in the plan.

In Rational Team Concert, you will track the creation of an iteration plan using work items. You will create a new work item, set the priority, estimate how long the work will take, complete the work, and update the work item accordingly.

3.1. Creating Work Items

a) Ensure you are logged into RTC. If you created a user in Module 1 then you can use that user. Alternatively you can use labuser99 which has been created for you already. To login right click on the labuser99@sharexp1 node in the Repository connections and select login. Or if using your own userid right click on labuser99 and select Properties as shown below.

b) In the dialog box select the Jazz Repository Connection on the left side of the screen. Then change the user id and password to the one you created previously (labuser#). The password is the same as the user id. Press OK.
c) If you get any certificate problems when connecting, just accept the certificate permanently:
d) Ensure that you are using the **Work Items** perspective (it should be open by default). Go to **Window → Open Perspective → Work Items** to open it if it is not already your perspective.

e) Create a new Task work item to implement a new Iteration Plan.

   i. Select the **Team Artifacts** view

   ii. Expand the **RTC Lab Project** project

   iii. Right-click on the **Work items** folder and then select **New→Work Item**.
iv. Select Work item type **Task** and click **Finish**
f) The Work Item editor will automatically open and will look like the picture below.

![Work Item Editor](image)

- For the details of the Task:
  
  - i. **Type** Create Iteration Plan in the **Summary**
  
  - ii. Fill in something useful and descriptive for the **Description**.
  
  - iii. **Set File Against** to RTC Lab Project
  
  - iv. **Set Owned By** to your lab user. You may need to select More… and then search for your userid by entering an * in the user name area.
  
  - v. **Set Priority** to High
  
  - vi. Leave **Planned For** as Unassigned - we will come back and fill this in later once we create an iteration plan.
  
  - vii. **In Estimate**, type 10 minutes
  
  - viii. **Save** the work item by clicking on the button in the upper-right corner titled **Save**.
ix. From the drop-down in the upper-right corner, select **Start Working**. You will close this work item once you are done with the next section.

x. Click **Save** in the upper-right corner of **Work Item** editor view.

h) To create a parent-child relationship with work items, to make a work item depend on another work item, create a blocking relationship, or categorize as a duplicate, go to the **Links** of the work item. This is also the tab where you can attach a file to a work item or add subscribers. Subscribers are users that get notified when changes are made to a work item. Create another work item so you can associate your first work item with the second. Click the **Add** button as seen in the picture below to link a Work Item to another with the aforementioned relationships.

![Image of Work Item editor view]

Select **Set Parent** in the presented drop down menu, and then on the next panel enter **3** as the ID. A workitem with the id of 3 should appear. Select this as the parent.
i) Save the task by clicking the save button in the upper-right corner. Your task should look similar to this after a successful save:
**Working on a work item**

There are several ways to designate a work item as the active work item:

1. Open the work item, set its status to Start Working and click Save.
2. From the Work Items view, drag the work item into the lower right-hand corner of the Eclipse main frame.
3. Right-click the `<no current work>` string lower right-hand corner of the Eclipse main frame and select Start Working or Recent Work to see a list of work items to work on.

There are several ways to deactivate an active work item:

1. Open the work item and set its status to Stop Working and click Save.
2. Right-click the work item in the lower right-hand corner of the Eclipse main frame and select Stop Working.

When you resolve an active work item, you are prompted to deliver the associated change sets. If you stop working on a work item or start a new change set while a work item is active, you will be prompted to suspend the changes associated with the active work item.
3.2. Creating an Iteration Plan

a) Ensure that you are using the Work Items perspective (it should be open by default).

b) You are ready to create a Plan what you will use to track your progress as a team over a period of time. Right-click on Plans, a child of RTC Lab Project, and select New → Plan.

c) Name the Iteration Plan Sprint 1.0. This is what your team (you) will use to track your progress throughout this Iteration (lab). You will create work items and associate them with this Iteration Plan. Associate the plan with a Project Area by clicking the Browse button next to Owner, selecting RTC Lab Project. Click Finish.
You may get an Open Plan dialog that asks where you want to open the plan, in the Web Client or in the Eclipse Client. We will use the Eclipse Client for now.

3.3. Populating plans with Work Items

a) Take some time to create a few work items following the steps in Section 3.1. Set them to be Planned for Release 1.0, and leave the owner as unassigned. Open the plan by navigating to RTC Lab Project → Plans → All Plans → Main Development → Release 1.0 → Release Backlog. You will see you start out with a blank page, this is a place for a textual description of the goals or plans for the sprint. Fill in some text and click save.

b) Click on the tab Planned Items at the bottom of the iteration plan window. You should see the following screen with with no work items yet assigned to any users.
c) We are first going to add items in the release into various sprints. So add items to the Sprint 1.0 or Sprint 2.0 plans by dragging them from the Release Work items List to the Sprint plans. Make sure you save once you are done. You will then have something that looks like this:

d) Now we want to assign these to specific users. So double click on Sprint 1.0 or Sprint 2.0, which ever has the most work items in it, and if presented with a screen select the sprint backlog. You will need to now change the View As from Iterations to Work Breakdown to view work items by owner. You will then see the following unassigned work items listed in the Sprint plan:
e) You can now drag a drop them on the user they should be assigned to. Open the work item and notice that both the Planned for and the assigned to has changed, save the changes and assign more tasks. Don’t forget to save the plan after adding work items.
Conclusion

This concludes the Lab for Module 3. You now know how iteration plans can be created, how to create work items and understand how they fit in the context of plans.
4.1. Predefined Queries

a) To search for work items, either create a query from scratch or use a predefined one. Try using predefined queries first. We will create queries in the next section. To use predefined queries, in the Team Artifacts view, navigate to RTC Lab Project → Work Items → Shared Queries → Predefined.
b) The predefined queries provide a useful set of basic queries that can be used. You can save queries you build to use in the future and even share them with your teammates! It can be useful to have queries that return results for a specific Iteration Plan, with a specific word or tag, to find work items based on any user, and even build complex Boolean statements using AND and OR expressions.

c) Results are displayed in the Work Item view as seen below when running the predefined query **Open created by me** by double clicking it. To open the Work Item view, go to **Window → Show View → Work Items**, but by running the query the view should be displayed automatically.
4.2. Creating Queries from scratch

a) Right-click on Work Items and select New → Query.

b) Click the link to Start from Scratch. Name your query something that describes what it searches for so you will know what it does. As an example we will create a query to search the summary text of a work item for the string 'Iteration'.

- Use the + sign in the upper-right corner to add a new condition. You can add as many as you need.
- In the Add Conditions... screen select Summary
- In the box provided enter the word Iteration. This is case sensitive so be careful. Click the Run button to see the results.
c) Try creating a more interesting query that searches based on more than one condition. By default, the conditions are added with a Boolean AND but you can change this to a Boolean OR by selecting OR from the dropdown menu as seen below.

d) Try creating complex queries with multiple conditions. When using queries, it is important to keep in mind that searches for text return true if the work item field contains the search text. There is no need to insert wildcards before and after search text.

e) To save a query, simply click on the Save button in the upper-right corner as seen below (the query must be named before it can be saved). Once a query is saved, it will appear in the My Queries subfolder as a child of Work Items.
f) To share a query amongst team members, go to the Details of the query as seen below with the Complex query example.

![Complex Query Details](image)

Click on Share → Team or Project Area and then choose RTC Lab Project. Your query is now shared amongst the team.

g) Click on Share → Team or Project Area and then choose RTC Lab Project. Your query is now shared amongst the team.

h) To further keep track of your work, you can add the new query to your Favorites folder. The Favorites folder is used to organize queries, plans and other artifacts that are important for your work. Drag the Complex Query query to the Favorites folder in the Team Artifacts view.

```
- RTC Lab Project [sharevimage1]
  - Builds
  - Enterprise Extensions
  - Plans
  - Reports
  - Source Control
  - Work Items
    - My Queries
    - Complex Query
    - Shared Queries
- RTC Lab Project - SHARE LPAR [mvs1.centers.1host.com]
  - Debug
  - Favorites
    - Complex Query
  - Feeds
  - My Repository Workspaces
```
i) It is not necessary to have the **Team Artifacts** view open to access the **Favorites** folder. At any time, press **Ctrl-Alt-F** (press the three keys simultaneously) and a popup dialog will appear with your favorites.

j) In the **Favorites** or **My Queries** folder, double-click your query titled **Complex Query**. The resulting work items are displayed in the **Work Items** view (That should be by default displayed at the bottom of the Eclipse client).

k) Experiment with quick search. In the bottom-left corner of the Eclipse client interface you find a drop-down list, expand it and select **All Work Items**.

l) In the text field next to the drop-down list, type in a word that appears in the title of several work items, for example type **Iteration** and press **Enter**. The result of this query is displayed in the **Work Items** view.

![Quick search](image)

**Quick search**

Try typing in a partial word (rat). Note that partial words do not match. Jazz uses a whole word indexer for work items for fast text queries. Try typing in a phrase that appears in a work item description somewhere. Note that the quick search does a full text search too.

**Conclusion**

This concludes the Lab for Module 4. You now know how to use predefined queries, create queries of your own, save them, add them to your favorites, and use the quick search to find work items.
Module 5  Web User Interface

5.1. Web User Interface: Work Items, Iteration Plans, Reports, Dashboards

a) The RTC web interface is another way to access work items, queries, and plans. To access the web interface, open Internet Explorer and go to https://sharexp1:9443/jts/web (also bookmarked as RTC Web interface) and login as user/password labuser99/labuser99 (or any valid user such as the user you created). You may need to get past a certificate error. If this is the case select Continue to this website.

b) Project Dashboards are customizable collections of viewlets which are meant to be a quick summary of important data. By default you are shown your personal dashboard which was created for you. There is also an RTC Lab Project Dashboard which was created by default when the project area was created. Try clicking the RTC Lab Project in the My Projects box to display it. Experiment with the dashboard by adding new tabs and adding viewlets to those tabs.

To get back to your own personal dashboard click on the drop down arrow next to your user name at the top right of the screen and then select Open My Personal Dashboard. However this is just for information; do not select your dashboard for now.
c) The next link on the top is **Work Item**. Click on it and you will see options to search for a work item, create a new work item, create a new query, and execute predefined or user-defined saved queries. Notice the queries created previously in the client will display in the web interface too. This is because both interfaces point to the same data. Creating a work item and query is so similar to the instructions in the client that it will not be covered in the web interface section.

d) The next link at the top is **Plans**. Click on it and select **all plans** to see a list of the iteration plans associated with this project area as seen below.
e) Click on the **Sprint 2 → Sprint Backlog** plan to see the **Planned Items** as highlighted below to see a breakdown of the tasks, defects, enhancements, etc. associated with this project area.

f) The **Source Control** link at the top is where you can find history for streams and components. We will cover this more extensively in the source control section. Source control access is provided in the web for viewing of artifacts.
g) The Build link at the top is where you can look at the existing build definitions, build queues and build engines, look at the results of builds that have run, and submit a build. Builds will be discussed later in the lab.

h) Click on the Reports link at the top of the page. On the left there are several predefined reports.

Play around with some of the reports, for example the Work Items by owner report.
Conclusion

This concludes Module 5. You now should be familiar with the functions available in the web user interface. As you can see this is a valid alternative interface for those users who don’t need to work with source control, or do not want the heavy Eclipse client.
Module 6  Source Code Management (SCM)

6.1. Source Code Management with RTC

Some Jazz Terms Defined:

Project Area
The project area is the system's representation of a software project. The project area provides definition for the project deliverables, team structure, process, and schedule.

Team Area
The structure of the project teams is defined by one or more team areas. A team area serves these functions:
1. Defines the users (team members) on the team and specify their roles.
2. Defines the development line in which the team is participating.
3. Customizes the project process for the team.

Streams and Components
A stream is a repository object that includes one or more components. A component is a collection of related artifacts, such as an Application, an Eclipse plug-In, or a group of documents that comprise Web site content.

Change Set
A change set is a repository object that collects a related group of changes so that they can be applied to a flow target (workspace or stream) in a single operation.

The change set is the fundamental unit of change in Jazz source control. The contents of any workspace, component, or stream can be expressed as a collection of change sets, beginning with the one created when the initial set of projects was checked in. A change set can include changes to the contents of individual files and changes to a component namespace (such as delete, rename, and move operations).

The source control component handles the storing, retrieving and sharing of source code and other artifacts in your project. It is important to understand the terminology and relationships involved in any model so we will give some background information on managing source code with RTC including terminology.

In Rational Team Concert, we want users to benefit from SCM's ability to track and version your changes, whether or not you are ready to share those changes with your team. Accordingly, as a user you have your own private repository workspace which stores the changes you've made, regardless of when you decide to make them available to your team. Sometimes it will be only a couple of hours before you decide to share your changes; sometimes it will be longer. You
decide when to make the changes available to your team. When you **load** your repository workspace, the files and folders in it are transferred to your Eclipse workspace on your computer. To push a change from your Eclipse workspace to the repository workspace you **check-in** the change.

A **stream** is used to store the team's work. When you want to make your changes available to your team, you **deliver** them from a repository workspace to a stream. When you wish to incorporate other team members' changes, you **accept** them from the stream (Note that you can also accept changes directly from another repository workspace, allowing for fine-grained sharing of changes between team members). For example, two team members might collaborate on a small bug fix; or, if someone starts a change and has to go on vacation, another team member could continue the work and then deliver it later. All changes you make in your repository workspace are tracked within change sets. Each change set is composed of a collection of explicit, primitive changes to one or more files or folders. The following picture shows the source control process.

![Source Control Process Diagram](image)

a) Ensure you are logged into RTC. If you created a user in Module 1 then you can use that user. Alternatively you can use labuser99 which has been created for you already. To login right click on the labuser99@sharexp1 node in the Repository connections and select **login**. Or if using your own userid right click on labuser99 and select **Properties** as shown below
b) In the dialog box select the Jazz Repository Connection on the left side of the screen. Then change the user id and password to the one you created previously (labuser#). Alternatively use the **labuser99** id that already exists. The password is the same as the user id. Press **OK**.
c) If you get any certificate problems when connecting, just accept the certificate permanently:
d) First, we are going to create a local repository workspace, to work with files in the repository. To do this, first locate your team stream for the project area **RTC Lab Project**. From the **Team Artifacts View**, expand **RTC Lab Project** project area and then expand the **Source Control** node. You should see a team stream named **RTC Lab Project Stream**.

e) Right-click on the **RTC Lab Project Stream** and select **New → Repository Workspace**.
f) Give the repository workspace a name such as Lab User # Repository Workspace where # is your user number and click Next.

![Image of repository workspace setup]

g) Select the current repository for the workspace

![Image of selecting repository]

Select repository
Select a repository where the workspace will be created.

- Use current repository labuser99@sharexp1
- Use another repository

Selecting a repository that is different from the flow target will create a distributed flow and cause components to replicate across servers. Initial replication may be a long process.
h) Next select the read access permissions, for the lab, make the workspace public, then click next.

![Read Access Permission](image)

- **Public**: Everyone in the repository will be able to see the files and change sets in all public components in the workspace. In addition, this repository workspace will appear in search results.
- **Private**: Only the owner will have read access to the repository workspace. The repository workspace won’t show up in searches. However, change sets in the public components will be visible to others.
- **Scoped**: Everyone with read access to the selected project area, will be able to see the files and contents in public components in this workspace.

i) Make sure all components are selected and load the repository workspace after creation is checked, click Finish.

![Components to Add](image)

- Check the box for **Load repository workspace after creation.**
Some Jazz terms reviewed

You use a personal Repository Workspace to work on project files under Source Control. You Load the repository workspace to copy the files and folders into your local workspace (Eclipse) on your computer. Jazz tracks all changes made to source-controlled files with Change-Sets. Each change-set itemizes the changes to one or more individual files or folders, carries a comment, and references the relevant work item motivating the changes. You Check-in your change-sets to upload copies of the modified files from your local workspace to the repository workspace.

j) You should now get a prompt for loading projects into your repository workspace. Make sure Find and Load Eclipse Projects is selected, and then click Finish. The components were already loaded as the original user of RTCadmin, so you will probably get a message asking which components to overwrite, select them all and then Finish.

k) If you get a request to overwrite then select all the projects and press Finish.
A loaded repository workspace will appear in the Pending Changes View. Loaded repository workspaces are special in that whenever you change a loaded file or folder in your Eclipse workspace, the changes are tracked and shown in the Pending Changes view. Here, you can manage your changes and perform common tasks such as

- Check-in changes to your repository workspace.
- Organize changes into change sets.
- Undo changes you’ve made.
- Associate change sets with work items.

If this view is not visible, go to Window → Show View → Other → Jazz Source Control → Pending Changes.

**Note:** Loaded means that the code in the repository has been copied down to your PC into a folder so that you can work on it. A loaded component is identified by the decorator. If you have a component in your Repository workspace that is not loaded then it is not filled out in blue, thus: 📁.
Other change-set operations:

Suspending a change set (suspend)

There might be times when you need to begin working on a new change set for a given set of items before you are finished with one that is in progress in your workspace. When in this situation, you can suspend the current change set, which removes it from your workspace but preserves it in the repository. The files in a suspended change set revert to the state they were in before the change set started, and the change set itself is moved to a special Suspended folder so that you can resume the work when you are ready.

Discarding a change set (discard)

There are two basic scenarios for discarding a change set:

Appendix A. If you have accepted an incoming change set but decide later that you don’t want it in your workspace, you can discard it to undo the accept and return the change set to the component's Incoming folder.

Appendix B. You can also discard a change set that you created but have not yet delivered. Discarded change sets of this type remain in the repository but are not placed in any special folder. To make it easier to retrieve a discarded change set that does not exist in any other stream or workspace, you can associate it with a work item before you discard it and then accept it from the work item later.

Reversing a change set (reverse)

If you want to undo the delivery of a change set, you can create a new change set that reverses all the changes in it and then deliver the reversed change set.

6.2. Working with Local Projects

In this section we are going to walk through the different artifacts related to resources for building them on z/OS. This will be based on an existing COBOL project that has already been created and is stored in the RTC SCM. As part of this lab you will explore the different artifacts, modify a COBOL part, and then build the sample application using Antz.

a) In this section we will work with an existing COBOL project loaded in RTC. We will use the functions of RDz to work with the parts. Make sure your repository workspace is loaded from the stream as done in the prior step, if it is not; load it now as you will be working with the files. First make sure you are in the work items perspective, if not Switch to the Work items perspective by going to Window → Open Perspective → Work Items.
b) In this view you will explore the new Data Set Definitions and Language Definitions sections. First start by expanding the Enterprise Extensions ➔ System Definitions ➔ z/OS ➔ Data Set Definitions, and double click to open the COBOL source codes definition. Data Set Definitions are used to define the datasets used on z/OS. These will include definitions for datasets used for source code that is placed in PDS/Es as well as the definition for the location of compilers, temporary datasets for build, and output datasets for build. Looking at this definition more closely you see this is a dataset used for source files copied to the PDS/Es. You will also notice this dataset will have a prefix added when used, this will be the users prefix when using RDz and the prefix defined in the build definition for team level builds. You will also notice this is where you define the dataset characteristics.
c) Now open the **COBOL compiler** dataset definition. In this definition you will see the compiler to be used. You will see more about how these dataset definitions are used in the next few steps. You notice in this definition, an existing dataset is used for build and the specific member is specified.
d) Expand **Language Definitions** Section and you will see Language Definitions, as well as Translators. Open the **COBOL compilation and link-edit** language definition. In this definition you specify the name of the language definition, any optional descriptions, language related, any associated file extensions such as `.cbl` and the translators used. The name and translators are required. The Translators are similar to the job steps to be performed for this language definition. Multiple translators can be used in each language definition. Each file, or module, will be associated with a language definition. The Language Definitions are then used when using Antz to perform the build and for integration with RDz.
e) Open the associated **COBOL compilation** Translator by expanding the Translators node. In this translator you see the actual step to be preformed, similar to a job step. The translator specifies the dataset definition which includes the name of the program to be run. The translator also specifies the parameters to be supplied for the compile, and the associated datasets.
f) Now let's drill into the zComponent Projects. A zComponent project is a special type of Eclipse project that has a z/OS nature. This means that there will be special processing involved for this type of project, such as translation to EBCDIC when files are sent to z/OS for compiling.

Add the Project explorer view to your workspace by selecting **Window ➔ Show View ➔ Other...**, in the filter box start typing Project Explorer until you see the node appear, then select it and click OK. In the Project Explorer open the **MortgageApplication-EPSCMORT** project by expanding the node. Open the zOSsrc folder and then the COBOL folder and look at the files.
Open the properties for the COBOL folder by right clicking on the COBOL folder and selecting properties. If you click on the **Enterprise Folder Properties** you will notice the specification of the associated dataset definition.

Similarly right click on the EPSCMORT file and select properties, again if you click on the **Enterprise File Properties** you will see the language definition associated with the file. You can change the language definition used at this point if required.

g) Now that we have an understanding of the definition for the zComponent project, let’s make a source code change. First create a new work item to track your changes, and start working on it. (See the working with work items section for detailed instructions.)
h) Once you are working on a work item. Double click on the EPSNBRVL COBOL file with the .cbl extension. You will see it has been opened in the RDz editor. Make some change in the comments, and save. To save a file, either right click inside the file and select Save, Just close the file and confirm you wish to save it when asked, select **file ➔ Save** from the main menu bar, or click the icon of the floppy disk on the toolbar.
i) Look at the pending changes view, it should be displayed below the source code. If not, open the view with **Window ➔ Show View ➔ Pending Changes**. You will now see that the Mortgage Application has a set of unresolved changes.

If you expand to see the file that changed, and double click on the file, the Text compare window will be displayed so that you can see what was added.
j) Go back to the Pending Changes View and right click on the Unresolved line, you will get the option to Check-in or Check-in and Deliver… This allows you to save the changes to your repository workspace, as well as to deliver them to the stream. Go ahead and select Check-in and Deliver.

k) Type a comment to go with the change set, and click Next. Select the work item you created that you are currently working on to associate to the change set. You may need to add the work item number into the search box to find it. And click Finish. Your code will now be delivered to the stream and the pending changes view will show no changes.
You could have just checked in the file, then worked on a bunch of other files and checked them into the same changeset. Then associate a workitem at one time to the complete changeset prior to delivering.

6.3. **Optional: Enabling Automatic Check-Ins**

a. Once a change is made to a versioned file (a file already being tracked by the Jazz Source Code repository), its corresponding change-set must be checked in to commit the change to your repository workspace. By default, check-ins must be initiated by the user. However, Rational Team Concert provides the option for making check-ins occur automatically.

b. Select **Window -> Preferences** to open the Preferences settings.

c. Expand **Team -> Jazz Source Control** and select **Check-in Policies**

d. Check **Auto check-in local changes** and press OK.
Conclusion

This concludes Module 6. You now should be familiar with source code management using the Eclipse GUI, along with the integration with the work items.
7.1. z/OS Antz Build

In this section we are going to create a build definition that will build the mortgage application. This build definition will use the RTC Ant with Enterprise Extensions capabilities to perform the build.

RTC uses a build agent that is running on the z/OS machine. This agent handles the transport of the parts to and from the RTC repository, plus the invocation of the build through the use of Ant XML build scripts. These are generally automatically generated for you.

a) Ensure you are logged into RTC. If you created a user in Module 1 then you can use that user. Alternatively you can use labuser99 which has been created for you already. To login right click on the labuser99@sharexp1 node in the Repository connections and select login. Or if using your own userid right click on labuser99 and select Properties as shown below

![Login Dialog](image)

b) In the dialog box select the Jazz Repository Connection on the left side of the screen. Then change the user id and password to the one you created previously (labuser#). The password is the same as the user id. Press OK.
c) If you get any certificate problems when connecting, just accept the certificate permanently:

![Repository Connection Certificate Problem]

There is a problem with the certificate presented by the server when connecting to 'sharevmimage1'. The certificate host name does not match the server host name.

Team Repository: https://sharevmimage1:9443/ccm/

What would you like to do?

- Reject this certificate and do not connect to this repository
- Accept this certificate temporarily for the remainder of this session
- Accept this certificate permanently

OK Cancel

d) Now that we have the artifacts defined let’s look at doing a build. Navigate back to the Team artifacts view and open the builds section. Under the builds, you should see a folder with the existing build engines, and a build definition for the Mortgage Application called RTC Lab Project build. We will step through this definition to make sure it is set up.
**Note:** On the lab system there may be other build engines and build definitions, such as the RTC Lab - MVS269 Engine and the RTC Lab Project MVS269 build. These are used for lab system set-up and can be ignored. Although if you are short of time, you can look at the RTC Lab Project MVS269 build to see what a successful build looks like.

e) Open the RTC Lab Project engine by right clicking the build engine and selecting **Open Build engine**. The first tab is an overview and mainly shows us the build definitions that use this build engine, this screen should look like this:
The Build Agent tab tells us where the build engine is running and provides connection information. For this lab, the build agent is running on the SHARE machine, make sure the build agent hostname is specified as `mvs1.centers.ihost.com` and the port number is `8420`. The user name is set to LXD1 with a password, this has been set up as the build user id. To verify you have a connection to the SHARE machine's build agent you can click the Test Connection button. You should get a connection with the following feedback:
f) Open the RTC Lab Project Build Definition by right clicking on the build definition and selecting **Open Build Definition**. The first tab is the overview tab, it provides the build name, the project or team area the build is associated with, any description for the build, supporting build definitions and pruning policy. The Build Definition should look like this:
g) Notice there are a number of tabs associated with the build definition. The second tab is the schedule tab, if this build would be a scheduled build, you could select when to have the build run automatically. The third tab is the properties tab, which allows you to specify additional properties for the build. You will need to set one of the properties in this tab, to specify the IP address of your server, such that the build engine can contact you back. To find your IP address, open a command prompt and type `ipconfig` and press enter. You should see this:

![Command Prompt output](image)

Remember your IP address, in this case 9.42.92.245, then open the properties tab of the build definition. You can edit the existing build property by highlighting the repositoryAddress line and clicking enter. Change `https://sharexp1:9443/ccm/` to be `https://x.x.x.x:9443/ccm/` where x.x.x.x is your IP address. The properties tab should look like this:

![Properties tab](image)

h) Select the Job Output Publishing page, here you specify to publish job output logs. The check box should be selected.

i) The next page is the Jazz Source Control – z/OS. This is the page that specifies what repository workspace should be used, and the specific load options. Make sure your repository workspace is selected, and specify the load directory as `/shareuser/sharaxx/RTCLab` and the dataset prefix as `SHARA01.RTCLAB`. Change `sharaxx` to the userid that you were told to log in with. Also make sure the delete directory before loading option is specified.
Note: If you have logged in as LABUSER99, you will still need to use your assigned mainframe ID or SHARAXx for the load directory and Data set prefix. This is because everyone cannot use and overwrite the Labuser99 data sets.

j) The last tab is the Dependency Build tab. This build definition has been set up as a dependency based build to only build what has changed, so in essence a smart build. There are some sub-tabs in the main tab. The first is a general tab where you can specify things here such as a modified build.xml file. However we are letting RTC generate a build file for us based on the language definitions used in our project. This tab is also used to specify any other Antz configuration parameters.
The Dependency options allow you to define some options such as to build only changed items or to only build certain programs. We don’t need to change anything here.

k) Once the build definition is updated, save the build definition using the **Save** button at the top right of the Build Definition. Once the Build Definition is complete it can be submitted. To submit the job, right click on the definition and click **Request Build**....
l) The Request Build definition is displayed click on the submit button to request the build.

![Request Build dialog box](image)

m) When the build runs, it will display in the builds view. If the builds view is not displayed double click on the build definition and it will display the builds window.
n) You should now have successfully run a build on the Mortgage Application. Your build should only have built what was required to be built based on the change you made. So, let’s go look at a build report. Double click on the build you just ran, and you can see the build report. On the first page you see the general information about the build.

There are also links to downloads and logs. If you click on the Logs page you will see all the output produced for the build, in this case the compiler output for COBOL compiles and BMS Map assembles:
This concludes Module 7. You now should be familiar with Enterprise build using Ant and Buildforge.
Module 8  Source code management with the ISPF Client

In this module, you will see how to start the RTC ISPF Client and use it to edit, check-in, deliver and build z/OS programs.

Many z/OS shops wanted to continue using the tools they were used to to work on mainframe programs, in particular ISPF edit. So RTC provided an ISPF Client that allowed the SCM operations of RTC to be performed through ISPF. Other operations around workitems, plans and admin would still be handled either from the Web UI or the Eclipse GUI.

Lab Scenario

You have been assigned the task of making a change to a COBOL program, testing it and then delivering it the stream for you colleagues to pick up. You will create a workitem through the web interface, and then use that workitem to make the changes to your code. Compile the code and then deliver it.

8.1. Logging into the SHARE LPAR

First of all you will need to logon to the SHARE LPAR.

To login, follow these steps:

- Double click on the “mainframe” or “TSO” icon on your desktop.
- At the application prompt, type TSO and press Enter.
- At the prompt, enter your userid (SHARAxX – you will be allocated a number).
- On the TSO/E Logon Panel, enter your password which is FIRSTPW.
- You should be presented with the SHARE ISPF Primary Option menu

8.2. Starting and logging into the ISPF Client

The ISPF Daemon is a started task that runs to handle all requests to the various RTC servers. The Daemon should already be running. If you are interested in looking at the daemon, go to SDSF with a prefix of ISPFDMN, and you will see the started task. Have a look through the job if you wish.

a) To start using the ISPF Client you will need to know the IP address of your RTC server running on your desktop. To find your IP address, open a command prompt and type ipconfig and press enter. You should see this:
Remember your IP address, in this case 9.42.92.245.

b) To start the ISPF Client enter **RTC** on the command line and press Enter, you will see the RTC primary screen:

![RTC Primary Screen](image)

**Menu**  
**Help**

---

**Rational Team Concert Primary Option Menu**

**Option ====>**

0 Settings  
Terminal and user parameters *** Not connected ***

1 Connections  
Work with connections to source User ID . . . :

2 Workspaces  
Work with repository workspaces Server . . . :

3 Edit  
Work with source data Project . . . :

4 Build  
Work with build options Release . . . :

X Exit  
Exit client

---

c) First thing we will check are your settings. This will tell the RTC Client on which port the daemon is running and additionally what the daemon registry directory is. These have to match what is set in the daemon you are pointing to. For this LPAR the daemon port is **8421** and daemon registry is **/shareuser/lxd1/jazz/ccm**.

---

**Menu**  
**Help**

---

**Command ====>**

**Preferences**

---

Share files in binary mode
Client Code Page  
IBM-1047
Client Time Zone
Daemon Port  
8421
Daemon Registry Directory  
/shareuser/lxd1/jazz/ccm
Daemon Timeout  
1200

---

[d) Press Enter to go back to the primary menu. We are now going to connect to our RTC Repository through the daemon. Select option 1 – Connections and press Enter, you will be presented with an empty repository connection screen. First step is to add your userid and repository address into the fields provided. If you have created your own labuserxx userid you
can use this, or else use labuser99 which has been created for you. For the repository address enter https://your-IP-address:9443/ccm/ where your-IP-address is the IP address returned from your IP config command.

e) Press enter and the connection will be added to the list. If you have multiple servers you can connect to you can add them all to the list to use for connection. Now you can enter an L next to the connection to login, or alternatively enter a “/” to see all available options:

You will be presented with a list of options, so just select 1 to login:
You will be presented now with a password screen where you can enter your Jazz repository password, which is the same as your userid, or if you are using labuser99, it will be labuser99. The password is a protected field so you will not see it as you type.

If you have never logged in before you will be presented with a screen to select a project area. Your RTC repository may have multiple project areas you can select from. The connection panel is also the place you can switch between project areas. For this lab there is a single project area, so select it with a “/”:

You should now be logged in and presented with the primary options panel to inform you of that:
8.3. Working with your repository workspaces

The first thing we need to do is load some PDSs with source code data from the RTC repository. On
z/OS the source needs to be in normal PDSs so that ISPF can edit the code and compilers can compile
it. The actions of the Eclipse GUI such as LOAD and SHARE have been propagated to the ISPF Client,
so regardless of which interface you use the processes are basically the same. So lets get started...

a) From the primary option menu sect option 2, to work with your repository workspaces.
Depending on which other lab modules you have worked will have an affect on what you see
next. If you are using LABUSER99 to log in, then you will see a screen with an existing
repository workspace. If you previously created a repository workspace, then again, you will
have one listed on the screen presented. If this is the case, skip to bullet d) to continue.

However, if you have dived straight into the ISPF Lab with your own userid, you may be
presented with an empty screen. If that is the case, enter a repository workspace name,
whatever you like, in the Name field provided and press enter:

```
Menu   Help

Rational Team Concert Primary Option Menu

Option ==> __________________________________________ Scroll ==> CSR

0 Settings   Terminal and user parameters
1 Connections Work with connections to source
2 Workspaces  Work with repository workspaces
3 Edit        Work with source data
4 Build       Work with build options
X Exit        Exit client

****** Logged in ******
User ID . . : labuser99
Server. . . : 9.190.179.178
Project . . : RTC Lab Proje
Release . . : 3.0

Note: Many of the fields in RTC are what are know as scrollable fields in ISPF. So for fields
where the information is too long for the available width you can still get the rest of the
information. Position the cursor somewhere in a field, for example under the actual project
name “RTC Lab Proje..”, then press PF4. A panel is displayed with the information. Some
scrollable fields are updatable, so you can press PF4 to enter additional data. Alternatively,
with the cursor in a scrollable field just press PF10/PF11 to scroll the available data left and
right.
```
b) Enter the workspace visibility and select a stream to flow with using a “/”, there should only be one in the list, then press enter:

```
Menu Help

New Repository Workspace

Command ==> ____________________________ Scroll ==> CSR

Name . . . . MyRepositoryWorkspace

Description .

Visibility
1  1. Public
2  2. Private
3  3. Scoped

Stream:

/_ RTC Lab Project Stream

*************************************************************************** Bottom of data ***************************************************************************
```

c) Select the component you want to include, again in this lab there should be only one, and press enter:

```
Menu Help

New Repository Workspace

Command ==> ____________________________ Scroll ==> CSR

Enter ‘/’ to select

Components to add:

/_ Default Component (2:RTC Lab Project build_20110221-1635500312)

*************************************************************************** Bottom of data ***************************************************************************
```

d) You will now be presented with a list containing your repository workspace, where you will now be able to perform your next actions:

```
Menu Help

Repository Workspaces

Command ==> ____________________________ Scroll ==> CSR

Enter new repository workspace name to create or ‘/’ against existing repository workspace for options

Load location

Names

Data set prefix

z/OS UNIX dir.

MyRepositoryWorkspace

Valle Tests Stream Workspace

*************************************************************************** Bottom of data ***************************************************************************
```
If you enter a “/” next to the repository workspace you will see a list of actions that can be performed.

The main ones will be Load, Jump, Incoming Change Sets and Outgoing Change Sets. So we will concentrate on these for now.

The first thing we need to do is load a set of PDSs with the source code held in the repository so that we can begin working on it. Either from the list shown above select option 3 to perform a Load, or if you are still on the repository workspace list screen, enter a L to load. You will be presented with a screen where you have to enter your data set prefix. This is a high level qualifier, and most likely a middle level qualifier to identify where RTC is going to load the source data. You high level qualifier for this lab will need to be you SHARE LPAR userid, SHARAxx, that was assigned to you. For the middle level qualifier use something like RTCLAB. In the example shown the HLQ is DOHERTL. You can ignore the z/OS UNIX directory location for this Lab.
Press enter. You will be presented with a confirmation screen where you can just press enter again. The load may take some time as it transfers all of the source code data from the RTC repository to the PDS data sets it will create for you. RTC uses the data set definitions discussed in Module 6 to know what attributes to allocate a data set with. Once the load has finished you will be presented with the repository workspace screen, except the load location will now be filled in:

From here we can now easily jump to a data set list with our loaded data sets so we can begin making code changes. Enter a JD next to the repository workspace, and you will be taken to the data set list (similar to ISPF option 3.4) except for the data set pattern specified in the load location.

The next section will talk you though making program changes and checking programs in.

### 8.4. Making changes to programs

There are two ways to start editing members. The first is to use the Jump option from the repository workspace panel, to jump directly to the source code data panels, which we used in the previous section. You can use the J command to jump to the main option 3 panel, or the JD to jump directly to the data set list, or the JU to jump directly to the z/OS Unix directory list.

Alternatively you can start with option 3 on the RTC primary menu:
In this case you will be given a panel where you can enter your data set pattern, which works the same as ISPF option 3.4 or ISPF option 3.17 for z/OS Unix directories. In this case enter your data set pattern, which will be SHARAxx.RTCLAB, or whatever you used when you did your load.

Entering a "/" next to the Data Set Pattern and pressing enter will show data sets that match this pattern, which is the same panel you would be presented with if you had used the Jump option from the repository workspace panel:

| Data Set Pattern | DDHERTL.RTCLAB |
---|---|
| z/OS UNIX Directory | |
So we now have a list of data sets we can start working with to make some code changes. So let’s get started on that...

a) Enter an E next to the **SHARaxx.RTCLAB.COBOL** data set. Press enter and you will be presented with the member list for this dataset.

```
<table>
<thead>
<tr>
<th>Name</th>
<th>SCM</th>
<th>Lock</th>
<th>Changed</th>
<th>ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>EPSCMORT</td>
<td>2011/06/16 15:38:46</td>
<td>DOHERTL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EPSCSMRT</td>
<td>2011/06/16 14:28:56</td>
<td>DOHERTL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EPSMLIST</td>
<td>2011/06/16 14:28:56</td>
<td>DOHERTL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EPSMPHT</td>
<td>2011/06/16 14:28:56</td>
<td>DOHERTL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EPNBRVL</td>
<td>2011/06/16 14:28:56</td>
<td>DOHERTL</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

b) Enter an E next to the **EPSCMORT** member and press enter. You are now in the normal ISPF editor for this member. We are going to make a simple change. Just add an extra comment line with a comment of your choice, using the previous comment lines as an example:

```
000001     ID DIVISION.
000002     PROGRAM-ID. EPSCMRT.
000003     * THIS DEMONSTRATES CICS/DEBUG - EPSCMRT 2008
000004     *
000005     * THIS PROGRAM WILL RECEIVE A DATE AND CONVERT THE DATE TO
000006     * AN INTEGER IN A CALLED PROGRAM TO DETERMINE DAYS FROM
000007     * CURRENT DATE.
000008     *
000009     * (C) 2008 IBM - JIM HILDNER RESERVED.
000010     * Changed by Liam Doherty - March 2011. _
000011     ENVIRONMENT DIVISION.
000012     CONFIGURATION SECTION.
000013     SOURCE-COMPUTER. IBM-FLEX-ES.
000014     OBJECT-COMPUTER. IBM-FLEX-ES.
000015     *
000016     DATA DIVISION.
000017     WORKING-STORAGE SECTION.
```
Note: In COBOL an asterix in column 7 denotes a comment line.

c) Press PF3 to save and exit the member, and you will see that the member list display has been updated to show that you have edited the member. The * in the SCM column shows that you have an unchecked in change.

```
Menu Options Help

Command ===>

Source Control Row 1 to 7 of 7

Command - Enter "/" to select action

<table>
<thead>
<tr>
<th>Name</th>
<th>SCM</th>
<th>Lock</th>
<th>Changed</th>
<th>ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>EPSCMORT</td>
<td>*</td>
<td></td>
<td>2011/08/01 01:41:58</td>
<td>DOHERTL</td>
</tr>
<tr>
<td>EPSCSMRD</td>
<td></td>
<td></td>
<td>2011/06/16 14:26:56</td>
<td>DOHERTL</td>
</tr>
<tr>
<td>EPSCSMRT</td>
<td></td>
<td></td>
<td>2011/06/16 14:26:56</td>
<td>DOHERTL</td>
</tr>
<tr>
<td>EPSMLIST</td>
<td></td>
<td></td>
<td>2011/06/16 14:26:56</td>
<td>DOHERTL</td>
</tr>
<tr>
<td>EPSMPMT</td>
<td></td>
<td></td>
<td>2011/06/16 14:26:56</td>
<td>DOHERTL</td>
</tr>
<tr>
<td>EPNSBRVL</td>
<td></td>
<td></td>
<td>2011/06/16 14:26:56</td>
<td>DOHERTL</td>
</tr>
<tr>
<td>NEWPROJ</td>
<td></td>
<td></td>
<td>2011/06/16 11:47:59</td>
<td>DOHERTL</td>
</tr>
</tbody>
</table>

```

d) In order to check the member in, you are going to need to associate it with a work item. Currently, the SCM capabilities of the ISPF Client do not allow you to create workitems, so lets go to the web interface and create a workitem we can use. In a web browser use the URL https://localhost:9443/ccm/web/projects/RTC Lab Project

e) You will be presented with a login screen so enter your lab userid that you created previously or labuser99 if you are using that. Password is labuser99.
f) On the screen presented click on the workitems option in the menu bar at the top of the screen:

and then select a defect workitem to create
g) Enter a summary, description and file the defect against the RTC Lab Project and click Save. You should now have a defect number you can use. Change the status to “Start Working”. You also need to assign the workitem to yourself, so click the pulldown next to Owned By and select More…

On the select user panel shown, click Show all and then select the userid you are currently using, and click OK.
Once you return to the main panel click **Save**.

h) You can now return to your ISPF session where we can continue working with our change. Next to the member you changed, enter a **C** to check the change in, and press enter:

```
<table>
<thead>
<tr>
<th>Command</th>
<th>- Enter &quot;/*&quot; to select action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>SCM</td>
</tr>
<tr>
<td>FEP</td>
<td>EPSCMORT</td>
</tr>
<tr>
<td></td>
<td>EPSCSMRD</td>
</tr>
<tr>
<td></td>
<td>EPSCMRT</td>
</tr>
<tr>
<td></td>
<td>EPSMLIST</td>
</tr>
<tr>
<td></td>
<td>EPSMPNT</td>
</tr>
<tr>
<td></td>
<td>EPSNBRL</td>
</tr>
</tbody>
</table>
```

i) You will be presented with a panel where you can now associate your changeset with a workitem and add an optional comment. So enter a * in the workitem field and if you wish a comment in the comment line:
j) Once you press enter you will be presented with a list of unresolved workitems for which you are the owner, including the one you just created. Select the workitem you just created with a “/” and press enter.

k) You will be returned to the comment screen where, now that you have a workitem number assigned you can press enter again. If you know the workitem number you can, rather than entering an * to get a list, just enter the workitem number directly.
l) You will see that now you have pressed enter, the * in the SCM column has disappeared, showing that you have checked the code in. The next stage we need to perform is to build the program to make sure our change compiles.

8.5. Performing Builds

Before you can deliver your changes and make them available to the rest of the team you might want to compile and test your program. So let’s explore the build options available from the ISPF Client.

a) To get to the build options we could PF3 out until we went back to the RTC Primary option menu. But instead we are going to use the Action Bar choices on the RTC menus. Position your cursor on the Menu bar and press enter and the action bar menu should be displayed.

b) The Builds panel should be displayed with a list of the different build definitions. You may need to enter an * in the filter and then press enter. There should only be one build definition for this Lab and it should show that last status of the build. In the example below, that is completed.

c) To view previous builds enter a V, or if you want to request a new build enter an R, or enter a “/” to see available options. For this lab we will enter a V to view any previous builds. This will show us, much like the Eclipse GUI a list of all the previous builds and their current status.
d) We now want to start a personal build to build the code changes we have made in our own personal repository workspace. So next to any one of the existing builds enter a R to request a build. This will display the Submit Build Request panel, which shows the build properties we will be using. However we want to submit a personal build so that it uses our own repository workspace and build data sets. So select the Personal Build option with a “/” and enter an S on the command line to submit the build.

e) On the personal build options screen you need to select the repository workspace to use with a “/”. You also need to enter your data set prefix and load directory. For the data set prefix you can use the same settings as you did for the load, so SHARAxx.RTCLAB. For the load directory we need to specify a work location that RTC will use for the build xml files. Use /shareuser/sharaxx/rtclab where sharaxx is your SHARE LPAR userid.
Press Enter and you may be presented with the Dependency Build options screen. In this case make sure Build all programs is set with a "/".

Press Enter and you will be returned to the Build results screen, where you will see the build is **pending**. If you press Enter you will see the status change to **In Progress**. The build may take some time, but should only build your 1 changed program.

**Note:** There is a chance the build may have built the BMS Maps for your project as well.

If you want to check your build results you can do so through the Eclipse GUI or through the Web UI. As the Eclipse GUI is covered in Modules 6 and 7, we will check the build output via the Web UI. In a web browser use the URL **https://localhost:9443/ccm/web/projects/RTC Lab Project**. You may need to login again using your userid or labuser99. On the main dashboard screen you will see the builds tab along the menu bar. Select that and then select the Build Engines option.
g) On the next screen, click on the link for the RTC Build engine.

h) You will then be presented with a list of build results, similar to that shown in the ISPF Client. You should see that the last one is the personal build that you submitted from your ISPF session. If you hover your mouse over the link you will get a popup giving you some details about the build.
i) You can then select the link to take you into the build results. From here you can click on the tabs to show you various things. The one we are interested in is the Logs tab. Once you click that you will see all the compiler outputs. In this example we also have the BMS output, but we are interested in the SYSPRINT output from the compile of EPSCMORT, that we changed previously.
Click on the link for the COBOL compile and the system should download the file. You should now be able to view the file with a text editor such as Notepad.

8.6. Delivering your changes to the stream

Now that you have successfully made a change to your programs, you are ready to deliver those changes to the projects stream so that you can share them with the rest of your team. This is a simple process.

a) Either from the RTC main menu, select option 2 – Workspaces or select the Menu action bar choice, press enter and 3 – Repository Workspaces. The repository workspaces panel will be displayed, and you will notice in the prefix area a > symbol. This shows we have outgoing changes that we can deliver. If the was a < symbol, then this would signify we had incoming changes to accept.
b) You can use the “/” to bring up a list of available options, or in this case just enter an O to bring up the outgoing changes panel.

---

Menu   Help

Outgoing Change Sets          Row 1 to 1 of 1
Command =>                             Scroll => CSR

Repository Workspace MyRepositoryWorkspace

Command - Enter ‘/’ to select action

<table>
<thead>
<tr>
<th>Comment</th>
<th>Creator</th>
<th>Date Created</th>
</tr>
</thead>
<tbody>
<tr>
<td>11: Change EPSCMORT for Lab</td>
<td>Lab User 99</td>
<td>2011/02/23 01:43:47</td>
</tr>
</tbody>
</table>

* * * Bottom of data * * *

---

c) You will see the changeset, and the workitem you attached to it listed. If you wish to see what files are being delivered you can enter a V to list the files.

---

Menu   Help

Change Set Details          Row 1 to 1 of 1
Command =>                             Scroll => CSR

Change set 11: Change EPSCMORT for Lab project-Changed the

Path

/MortgageApplication-EPSCMORT/zOSsrc/COBOL/EPSCMORT.cbl

* * * Bottom of data * * *

Alternatively, enter a “/” to get the available options. For example you can associate this changeset with a different workitem if you require.

d) Press PF3 to go back. Now enter a D to deliver the change to the stream. Once complete you will get a confirmation message.

---

Menu   Help

Outgoing Change Sets          Deliver completed
Command =>                             Scroll => CSR

Repository Workspace MyRepositoryWorkspace

Command - Enter ‘/’ to select action

<table>
<thead>
<tr>
<th>Comment</th>
<th>Creator</th>
<th>Date Created</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

* * * Bottom of data * * *

e) Your changes have now been delivered to the project stream, so any team mates who have this component in their repository workspaces will now be able to accept your changes and merge them with their own.
Conclusion

This concludes Module 8. You now should be familiar with source code management using the RTC ISPF Client.
Module 9  Optional: Exploring Changes and Traceability

In this module, you will explore a work item to demonstrate how information is linked within Jazz. There are some basic questions that this lab will answer:

- What changes were made for a work item?
- Who changed this file, and why?
- What are the specific changes made on this resource?
- How can we visualize the change history for this resource?

Lab Scenario

This is a good time to explore how Jazz links software artifacts in useful ways. You will now explore a part of the integration of Jazz Source Control Management with the rest of Jazz. You will also explore some of what can be done with change history.

9.1. What changes were made for a Work Item

Now you will explore the changes for a specific work item. This will allow you to see the specific files that changed. This makes the review process for the change easier.

a) Open a work item. Run a predefined query to search for Open Assigned To Me work items (See Section 3.1 for help with predefined queries). You should see something like the example picture below in your Work Items view (Window -> Show View -> Work Items).
b) From the **Work Items** view, double-click a work item. The work item below is just an example. Choose any work item from the search results.
c) Note the Change-sets link in the Quick Information section of the Overview tab and the detail in the Links tab. You will not see any change set information if a change set has not been associated with this work item (see Section 6 for information on how to associate a work item with a change set)
d) Note the work item’s **Change Sets** section in the **Links** tab above. Double click a change set to open the change set and see which source members were modified for the change. In the **Change Explorer** view you can double click on a source member to open the compare editor and to see exactly which lines were modified for the change. This can be done for any work item. Try exploring changes made in a Work Item.

**9.2. Who changed this file, when and why?**

This section covers looking at the capabilities of finding out what changes happened with a specific file. We will use the **MortgageApplication** program loaded in Section 6.

a. From the **Package Explorer** view (Window -> Show View -> Package Explorer), select any of the files that you have modified right-click on the file and select **Team -> Show History**.

b. The **History** view opens and shows who has made changes to the file and when those changes were made. You can now start to understand how the file has evolved over time. This can also help with someone who is new to the project so they know who to talk to.
when they have questions over certain files. The **Merges** column gives a graphical view of the change-set merges that have occurred over time on this file.

<table>
<thead>
<tr>
<th>Merges</th>
<th>Comment</th>
<th>Creator</th>
<th>Date Created</th>
</tr>
</thead>
<tbody>
<tr>
<td>17: Fix code problem in Mortgage Application - Fixed</td>
<td>Share projects</td>
<td>Lab User</td>
<td>10:30:58 AM (5 minute...</td>
</tr>
<tr>
<td>778: Update RFS Client to RDz 75 20080602_0359 - This version ...</td>
<td>Share projects</td>
<td>RTCz Admin</td>
<td>Aug 18, 2009 11:36 AM</td>
</tr>
</tbody>
</table>

**c.** Here is a second example of history for a part within the RTC source repository. It shows the different updates, who made them, and how the files were merged.

<table>
<thead>
<tr>
<th>Merges</th>
<th>Comment</th>
<th>Creator</th>
<th>Date Created</th>
</tr>
</thead>
<tbody>
<tr>
<td>778: Update RFS Client to RDz 75 20080602_0359 - This version ...</td>
<td>Share projects</td>
<td>Pascal Piantoni</td>
<td>Jun 12, 2008 9:50 AM</td>
</tr>
<tr>
<td>637: Update RTCz client code to be Ms-based - BE CAREFUL! This version ...</td>
<td>Share projects</td>
<td>Jean-Yves Rigolet</td>
<td>Apr 29, 2008 7:31 AM</td>
</tr>
<tr>
<td>778: Update RFS Client to RDz 75 20080602_0359 - This version ...</td>
<td>Share projects</td>
<td>Pascal Piantoni</td>
<td>Jun 12, 2008 9:50 AM</td>
</tr>
<tr>
<td>637: Update RTCz client code to be Ms-based - BE CAREFUL! This version ...</td>
<td>Share projects</td>
<td>Jean-Yves Rigolet</td>
<td>Apr 29, 2008 7:31 AM</td>
</tr>
<tr>
<td>390: RFS agent client code update to RTC MS - MS to MS code</td>
<td>Share projects</td>
<td>Pascal Piantoni</td>
<td>Mar 6, 2008 9:56 AM</td>
</tr>
</tbody>
</table>

**Conclusion**

This concludes Module 9. You should now be familiar with some of the traceability provided with Rational Team Concert. As you explore you will learn more of the history and traceability features.

**Lab Conclusion**

This lab has demonstrated the basic functionality of Rational Team Concert. Download your own copy from jazz.net and play all you want to learn more.

To use the sample code used in this lab go to:

https://jazz.net/wiki/bin/view/Main/DependencyBuildScenario

and for information on setting the build up go to:

https://jazz.net/wiki/bin/view/Main/DependencyBuildScenarioBuildEnvironmentSetup
Notices

© Copyright IBM Corporation 1992, 2012. All rights reserved.

U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A. IBM may not offer the products, services, or features discussed in this documentation in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this documentation. The furnishing of this documentation does not give you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku Tokyo 106, Japan
The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION AS IS WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

Intellectual Property Dept. for WebSphere Software
IBM Corporation
3600 Steeles Ave. East
Markham, Ontario
Canada L3R 9Z7

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this documentation and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

Copyright license

This information contains sample application programs in source language, which illustrates programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample
programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. © Copyright IBM Corp. 1992, 2007. All rights reserved

**Trademarks and service marks**

The following terms are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both.

1. IBM
2. z/OS
3. System z
4. Rational

Intel® and Pentium® are trademarks of Intel Corporation in the United States, other countries, or both.

Microsoft, Windows, Windows NT® and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of others.